summaryrefslogtreecommitdiffstats
path: root/arch/tde-deps/torsocks/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-deps/torsocks/PKGBUILD')
-rw-r--r--arch/tde-deps/torsocks/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/arch/tde-deps/torsocks/PKGBUILD b/arch/tde-deps/torsocks/PKGBUILD
new file mode 100644
index 000000000..0db591399
--- /dev/null
+++ b/arch/tde-deps/torsocks/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Contributor: Rorschach <r0rschach@lavabit.com>
+
+pkgname=torsocks
+pkgver=2.3.0
+pkgrel=2
+pkgdesc='Wrapper to safely torify applications'
+url='https://gitweb.torproject.org/torsocks.git/'
+arch=('powerpc64le')
+license=('GPL2')
+depends=('tor')
+backup=("etc/tor/${pkgname}.conf")
+source=(https://people.torproject.org/~dgoulet/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.asc})
+sha512sums=('4888caaffdcfebf3673e14f3491eae6aa84ca0a4a2a812ba7bdac2abb471307e89a3c5cffe7691fb6f190c7bd9ea455ee9a223d909a39152be8524f590be2031'
+ 'SKIP')
+validpgpkeys=('B74417EDDF22AC9F9E90F49142E86A2A11F48D36')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: