summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/abakus/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/abakus/debian/rules')
-rwxr-xr-xdebian/_base/applications/abakus/debian/rules40
1 files changed, 0 insertions, 40 deletions
diff --git a/debian/_base/applications/abakus/debian/rules b/debian/_base/applications/abakus/debian/rules
deleted file mode 100755
index 8ab9fb501..000000000
--- a/debian/_base/applications/abakus/debian/rules
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/make -f
-
-# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
-# Also include the main Trinity path
-ifeq ("$(LD_LIBRARY_PATH)", "")
-LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
-else
-LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
-endif
-export LD_LIBRARY_PATH
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_KDE_APIDOX := yes
-
-CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
-
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-debian/abakus.xpm: icons/hi64-app-abakus.png
- convert -resize 32 $< $@
-
-common-build-arch:: debian/abakus.xpm
-
-common-install-arch::
- install -D -m 644 debian/abakus.xpm debian/abakus-trinity/opt/trinity/share/pixmaps/abakus.xpm
- chrpath -d debian/abakus-trinity/opt/trinity/bin/abakus
- dh_icons -pabakus
-
-binary-install/abakus-trinity::
- mv debian/abakus-trinity/usr/share/man debian/abakus-trinity/opt/trinity/share/
-
-clean::
- rm -f debian/abakus.xpm