summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/piklab/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/piklab/debian/rules')
-rwxr-xr-xdebian/_base/applications/piklab/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/_base/applications/piklab/debian/rules b/debian/_base/applications/piklab/debian/rules
new file mode 100755
index 000000000..f16888762
--- /dev/null
+++ b/debian/_base/applications/piklab/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+# Currently is not possible to build piklab with --enable-final
+DEB_BUILD_OPTIONS += noopt
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+binary-install/piklab-trinity::
+ mv debian/$(cdbs_curpkg)/opt/trinity/share/man/man1/piklab.1x debian/$(cdbs_curpkg)/opt/trinity/share/man/man1/piklab.1