summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies/libcarddav/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/dependencies/libcarddav/debian/rules')
-rwxr-xr-xdebian/_base/dependencies/libcarddav/debian/rules144
1 files changed, 49 insertions, 95 deletions
diff --git a/debian/_base/dependencies/libcarddav/debian/rules b/debian/_base/dependencies/libcarddav/debian/rules
index 38c17ea44..22b8c9e32 100755
--- a/debian/_base/dependencies/libcarddav/debian/rules
+++ b/debian/_base/dependencies/libcarddav/debian/rules
@@ -1,110 +1,64 @@
-#!/usr/bin/make -f
+#! /usr/bin/make -f
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
+DEB_TIME64_API = $(shell echo | cc $(dpkg-buildflags --get CPPFLAGS) -dM -E -x c++ - | grep -q "_TIME_BITS 64" && echo true || false)
+ifeq ($(DEB_TIME64_API),true)
+DEB_TIME64_SUFFIX = 0t64
+else
+DEB_TIME64_SUFFIX =
+endif
-export CFLAGS = -g
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -O0
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
-CFLAGS += -O3
+ CMAKE_INSTALL_LIBDIR = lib
endif
-# Suppress accidental execution of the auto-* tools, c.f.
-# http://lists.debian.org/debian-devel/2001/debian-devel-200111/msg01416.html
-no_auto_tools = ACLOCAL="`pwd`/missing aclocal" \
- AUTOCONF="`pwd`/missing autoconf" \
- AUTOMAKE="`pwd`/missing automake" \
- AUTOHEADER="`pwd`/missing autoheader"
-
-make_flags = moduledir=/usr/lib/gdk-imlib2 $(no_auto_tools)
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
+ -DWITH_ALL_OPTIONS="ON" \
+ -DBUILD_ALL="ON"
post-patches::
dh_testdir
-
-build: post-patches build-stamp
-build-stamp:
- dh_testdir
- ./autogen.sh
- ./configure --prefix=/usr \
- --mandir=/usr/share/man
- $(MAKE) $(make_flags)
-
- touch build-stamp
+ifeq ($(DEB_TIME64_API),true)
+ # update library package name for TIME64 ABI
+ ls -d debian/* | \
+ grep -E "/libcarddav\." | \
+ grep -v "\.t64$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.t64 ] || \
+ (cp -a $$a debian/libcarddav$(DEB_TIME64_SUFFIX).$${a##*.} && mv $$a $$a.t64); \
+ done
+ [ -f debian/control.t64 ] || \
+ sed -i.t64 \
+ -e "s/^Package: \\(libcarddav\\)$$/Package: \\1$(DEB_TIME64_SUFFIX)\\nReplaces: \\1\\nBreaks: \\1/" \
+ -e "s/\\(libcarddav\\) (=/\\1$(DEB_TIME64_SUFFIX) (=/" \
+ debian/control
+endif
clean::
dh_testdir
- dh_testroot
- rm -f build-stamp
-
- [ ! -f Makefile ] || $(MAKE) clean
- [ ! -f Makefile ] || $(MAKE) distclean
-
dh_clean
-install: DH_OPTIONS=
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- $(MAKE) $(make_flags) DESTDIR=`pwd`/debian/tmp install
-
- dh_movefiles
-
- # Library package
- dh_install -plibcarddav --autodest debian/tmp/usr/lib/libcarddav.so*
-
- # Developer package
- dh_install -plibcarddav-dev --autodest debian/tmp/usr/lib/libcarddav.la
- dh_install -plibcarddav-dev --autodest debian/tmp/usr/include/libcarddav/*
- dh_install -plibcarddav-dev --autodest debian/tmp/usr/lib/pkgconfig/*
-
-# This single target is used to build all the packages, all at once, or
-# one at a time. So keep in mind: any options passed to commands here will
-# affect _all_ packages. Anything you want to only affect one package
-# should be put in another target, such as the install target.
-binary-common:
- dh_testdir
- dh_testroot
- dh_installdocs -A debian/README.Debian
- dh_installexamples
- dh_installmenu
- dh_installcron
- dh_installinfo
- dh_installchangelogs ChangeLog
- dh_link
- dh_compress
- dh_fixperms
- dh_strip
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-# Build architecture independent packages using the common target.
-binary-indep: build install
- $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
-
-# Build architecture dependent packages using the common target.
-binary-arch: build install
- $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
-
-# Any other binary targets build just one binary package at a time.
-binary-%: build install
- make -f debian/rules binary-common DH_OPTIONS=-p$*
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+ifeq ($(DEB_TIME64_API),true)
+ # revert library package name for TIME64 ABI
+ ls -d debian/* | \
+ grep -E "\.t64$$" | \
+ while read a; do \
+ mv $$a $${a%.t64}; \
+ done
+ ls -d debian/* | \
+ grep -E "/libcarddav$(DEB_TIME64_SUFFIX)\." | \
+ xargs -r rm
+ [ ! -f debian/control.t64 ] || \
+ mv debian/control.t64 debian/control
+endif