summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xdebian/_base/dependencies/tqtinterface/debian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/_base/dependencies/tqtinterface/debian/rules b/debian/_base/dependencies/tqtinterface/debian/rules
index 5772f17f6..0db17ad7b 100755
--- a/debian/_base/dependencies/tqtinterface/debian/rules
+++ b/debian/_base/dependencies/tqtinterface/debian/rules
@@ -7,8 +7,15 @@ include debian/cdbs/debian-tde.mk
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR)