summaryrefslogtreecommitdiffstats
path: root/debian/_base/metapackages/trinity-apt-archive/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/metapackages/trinity-apt-archive/debian/rules')
-rwxr-xr-xdebian/_base/metapackages/trinity-apt-archive/debian/rules37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/_base/metapackages/trinity-apt-archive/debian/rules b/debian/_base/metapackages/trinity-apt-archive/debian/rules
new file mode 100755
index 000000000..063ee8468
--- /dev/null
+++ b/debian/_base/metapackages/trinity-apt-archive/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DISTRIBUTION := $(shell dpkg-parsechangelog | grep ^Distribution: | cut -d' ' -f2)
+ARCHITECTURE := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+pre-build:: debian/stamp-distrospecific
+
+debian/stamp-distrospecific:
+ dh_testdir
+ [ -e debian/stamp-distrospecific ] || \
+ ls -a1 debian/distrospecific | grep -v "^\.*$$" | \
+ tee debian/stamp-distrospecific | \
+ tr "\n" "\0" | (cd debian/distrospecific && xargs -r0 mv -t ../..)
+
+clean::
+ dh_testdir
+ [ ! -e debian/stamp-distrospecific ] || \
+ cat debian/stamp-distrospecific | \
+ tr "\n" "\0" | xargs -r0 mv -t debian/distrospecific
+ rm -f debian/stamp-distrospecific
+
+binary-install/trinity-apt-archive::
+ dh_testdir
+ sed -i -e 's|<distribution>|${DISTRIBUTION}|' -e 's|<arch>|${ARCHITECTURE}|' debian/$(cdbs_curpkg)/etc/apt/sources.list.d/trinity.list