summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/tdeio-apt/debian/fixrpath
diff options
context:
space:
mode:
Diffstat (limited to 'debian/lenny/applications/tdeio-apt/debian/fixrpath')
-rwxr-xr-xdebian/lenny/applications/tdeio-apt/debian/fixrpath25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/lenny/applications/tdeio-apt/debian/fixrpath b/debian/lenny/applications/tdeio-apt/debian/fixrpath
new file mode 100755
index 000000000..0ca44359e
--- /dev/null
+++ b/debian/lenny/applications/tdeio-apt/debian/fixrpath
@@ -0,0 +1,25 @@
+#!/bin/sh
+# $Id: fixrpath,v 1.1 2006/11/19 12:01:24 lpnotfr Exp $
+# libtool -rpath workaround based on a suggestion by Yann Dirson
+# <dirson@debian.org>
+#
+# It is supposed to be inserted in configure.in, but I didn't want
+# to re-run autoconf (since that bloats the Debian diff unnecessarily),
+# so I just patch libtool after running configure. -- Richard Braakman
+# <dark@xs4all.nl>
+#
+# The version of libtool included with LessTif unfortunately insists on
+# linking with -rpath, i.e. hardwiring locations. This is not desirable.
+#
+# The dummy define is improbable enough not to conflict with anything; it is
+# just here to fool libtool by making it believe it gave some useful info to
+# gcc.
+#
+# This will also patch the generated libtool to explicitly
+# link libraries against the libraries they depend on. (particularly libc)
+
+sed < $1/libtool > $1/libtool-2 \
+ -e 's/^hardcode_libdir_flag_spec.*$/hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ "/' \
+ -e '/^archive_cmds="/s/"$/ \$deplibs"/'
+mv $1/libtool-2 $1/libtool
+chmod 755 $1/libtool