summaryrefslogtreecommitdiffstats
path: root/dilos/dependencies/sip4-tqt/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/dependencies/sip4-tqt/debian/control')
-rw-r--r--dilos/dependencies/sip4-tqt/debian/control70
1 files changed, 61 insertions, 9 deletions
diff --git a/dilos/dependencies/sip4-tqt/debian/control b/dilos/dependencies/sip4-tqt/debian/control
index 062fca734..08cddf311 100644
--- a/dilos/dependencies/sip4-tqt/debian/control
+++ b/dilos/dependencies/sip4-tqt/debian/control
@@ -4,20 +4,21 @@ Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Bernd Zeimetz <bzed@debian.org>, Michael Casadevall <mcasadevall@debian.org>
-Build-Depends: debhelper (>= 9~), python-all-dev (>= 2.3.5-10), python-all-dbg [!solaris-any], python-support (>= 0.7.1) | python-dev (>= 2.6.6-3~), libtqtinterface-dev, bison, flex
+Build-Depends: debhelper (>= 9~), python-all-dev (>= 2.3.5-10), python-all-dbg [!solaris-any], python3-all-dev, python3-all-dbg [!solaris-any], python-support (>= 0.7.1) | dh-python, libtqtinterface-dev, bison, flex
Standards-Version: 3.8.4
XS-Python-Version: all
+X-Python3-Version: >= 3.0
Package: python-sip-tqt
Architecture: any
Section: python
Replaces: python-sip-tqt (<< 4:14.0.0~)
Breaks: python-sip-tqt (<< 4:14.0.0~)
-Provides: ${python:Provides}, sip-api-7.0, sip-api-7.1
+Provides: ${python:Provides}
Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}
Conflicts: python-sip4 (<< 4.10)
Description: Python/C++ bindings generator runtime library
- SIP is a tool for generating bindings for C++ classes with some ideas
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
@@ -31,7 +32,7 @@ Provides: ${python:Provides}
Depends: python-sip-tqt (= ${binary:Version}), python-dbg, ${shlibs:Depends}, ${misc:Depends}
Conflicts: python-sip4-dbg (<< 4.10)
Description: Python/C++ bindings generator runtime library (debug extension)
- SIP is a tool for generating bindings for C++ classes with some ideas
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
.
@@ -47,17 +48,17 @@ Recommends: python-sip-tqt (>= ${source:Version})
Provides: python-sip-dev, python-sip4-dev, sip4
Conflicts: python-sip-dev, python-sip4-dev (<< 4.10), sip4 (<< 4.10)
Description: Python/C++ bindings generator development files
- SIP is a tool for generating bindings for C++ classes with some ideas
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
.
- SIP was originally designed to generate Python bindings for TDE and so
+ SIP-TQt was originally designed to generate Python bindings for TDE and so
has explicit support for the signal slot mechanism used by the TQt/TDE
class libraries.
.
Features:
- - connecting Qt signals to Python functions and class methods
- - connecting Python signals to Qt slots
+ - connecting TQt signals to Python functions and class methods
+ - connecting Python signals to TQt slots
- overloading virtual member functions with Python class methods
- protected member functions
- abstract classes
@@ -66,4 +67,55 @@ Description: Python/C++ bindings generator development files
- static member functions.
.
This package contains the code generator tool and the development headers
- needed to develop Python bindings with sip.
+ needed to develop Python bindings with sip-tqt.
+
+Package: python3-sip-tqt
+Architecture: any
+Section: python
+Provides: ${python3:Provides}
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: Python 3/C++ bindings generator runtime library
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
+ borrowed from SWIG, but capable of tighter bindings because of its
+ specificity towards C++ and Python.
+ .
+ This package provides SIP-TQt with support for Python 3
+
+Package: python3-sip-tqt-dev
+Architecture: any
+Section: python
+Depends: ${python:Depends}, python3-sip-tqt (= ${binary:Version}), python-all-dev, ${shlibs:Depends}, libjs-jquery, ${misc:Depends}
+Recommends: python3-sip-tqt (>= ${source:Version})
+Description: Python/C++ bindings generator development files
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
+ borrowed from SWIG, but capable of tighter bindings because of its
+ specificity towards C++ and Python.
+ .
+ SIP-TQt was originally designed to generate Python bindings for TDE and so
+ has explicit support for the signal slot mechanism used by the TQt/TDE
+ class libraries.
+ .
+ Features:
+ - connecting TQt signals to Python functions and class methods
+ - connecting Python signals to TQt slots
+ - overloading virtual member functions with Python class methods
+ - protected member functions
+ - abstract classes
+ - enumerated types
+ - global class instances
+ - static member functions.
+ .
+ This package contains the code generator tool and the development headers
+ needed to develop Python 3 bindings with sip-tqt.
+
+Package: python3-sip-tqt-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: python3-sip-tqt (= ${binary:Version}), python3-all-dbg, ${shlibs:Depends}, ${misc:Depends}
+Description: Python 3/C++ bindings generator runtime library
+ SIP-TQt is a tool for generating bindings for C++ classes with some ideas
+ borrowed from SWIG, but capable of tighter bindings because of its
+ specificity towards C++ and Python.
+ .
+ This package contains debugging symbols for python3-sip-tqt