summaryrefslogtreecommitdiffstats
path: root/gentoo/Documentation/scripts/usefull_commands
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/Documentation/scripts/usefull_commands')
-rw-r--r--gentoo/Documentation/scripts/usefull_commands15
1 files changed, 15 insertions, 0 deletions
diff --git a/gentoo/Documentation/scripts/usefull_commands b/gentoo/Documentation/scripts/usefull_commands
new file mode 100644
index 000000000..8ecaa9888
--- /dev/null
+++ b/gentoo/Documentation/scripts/usefull_commands
@@ -0,0 +1,15 @@
+# Per ebuild check and commit
+for I in <packages> ; do cp kate/metadata.xml $I; ebuild $I/$I-3.9999.ebuild digest; git add $I; git commit -m $I; done
+for I in kstart ksystraycmd ksysguard nsplugin kate kxkb ; do cp kate/metadata.xml $I; ebuild $I/$I-3.9999.ebuild digest; git add $I; git commit -m $I; done
+
+# update trinity live lists
+find trinity-base/ -iname '*9999.ebuild' | while read eb; do PN="$(basename $(dirname ${eb}))"; C="$(basename $(dirname $(dirname ${eb})))"; P="$(basename ${eb%%.ebuild})"; echo "~$C/$P"' **'; done | tee Documentation/trinity.live.keywords
+
+# update all manifests
+find . -iname *.ebuild | while read eb; do ebuild $eb digest; done
+
+# run ./test_separate_compilation.sh
+cat Documentation/derived-lists/<LIST> | sed 's/#.*//;s/^\s*//;s/\s*$//;/^\s*$/d' |xargs bash ./test_separate_compilation.sh
+
+# update manifests which older thatn ebuilds
+find . -iname *.ebuild | while read eb; do ma="$(dirname $eb)/Manifest"; find $(dirname $eb) -type f | while read f; do [ $f -nt $ma ] && ebuild $eb digest && touch $ma; done; done