summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/arts/arts-3.5.13.2.ebuild')
m---------gentoo0
-rw-r--r--gentoo/trinity-base/arts/arts-3.5.13.2.ebuild60
2 files changed, 0 insertions, 60 deletions
diff --git a/gentoo b/gentoo
new file mode 160000
+Subproject 644110a847c5911c2eb04eb53c93031740561ef
diff --git a/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild b/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild
deleted file mode 100644
index a788528e4..000000000
--- a/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-
-TRINITY_MODULE_TYPE="dependencies"
-TRINITY_MODULE_NAME="${PN}"
-
-inherit trinity-base
-
-set-trinityver
-
-DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
-HOMEPAGE="http://trinitydesktop.org/"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa -artswrappersuid jack mp3 nas vorbis"
-SLOT="${TRINITY_VER}"
-
-DEPEND="dev-qt/tqtinterface
- dev-libs/glib:2
- media-libs/audiofile
- mp3? ( media-libs/libmad )
- nas? ( media-libs/nas )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libogg media-libs/libvorbis )
- jack? ( >=media-sound/jack-audio-connection-kit-0.90 )"
-RDEPEND="${RDEPEND}"
-
-src_configure() {
- mycmakeargs=(
- -DAUDIOFILE=ON
- $(cmake-utils_use_with mp3 MAD)
- $(cmake-utils_use_with nas NAS)
- $(cmake-utils_use_with alsa ALSA)
- $(cmake-utils_use_with vorbis VORBIS)
- $(cmake-utils_use_with jack JACK)
- # NOTE: WITH_ESD dropped due to remove of esound long ago
- )
-
- trinity-base_src_configure
-}
-
-src_install() {
- trinity-base_src_install
-
- # used for realtime priority, but off by default as it is a security hazard
- use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
-}
-
-pkg_postinst() {
- if ! use artswrappersuid ; then
- elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
- elog "and so avoid possible skips in sound. However, on untrusted systems this"
- elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
- elog "priority, and so is off by default. See bug #7883."
- elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
- fi
-}