summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild')
-rw-r--r--gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild b/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
new file mode 100644
index 000000000..2a7c868ff
--- /dev/null
+++ b/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdegraphics"
+
+inherit trinity-meta
+
+DESCRIPTION="kfile plugins from kdegraphics"
+KEYWORDS="x86 amd64"
+IUSE="tiff openexr pdf"
+
+DEPEND="
+ tiff? ( media-libs/tiff:= )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ pdf? ( app-text/poppler )"
+RDEPEND="$DEPEND"
+
+PATCHES=( "$FILESDIR/tdegraphics-poppler-tqt-remove-unnecessary-check.patch" )
+TSM_EXTRACT_ALSO="kghostview/dscparse/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with openexr OPENEXR)
+ $(cmake-utils_use_with pdf PDF)
+ )
+
+ trinity-meta_src_configure
+}