summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/khotkeys/khotkeys-3.5.13.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/khotkeys/khotkeys-3.5.13.2.ebuild')
-rw-r--r--gentoo/trinity-base/khotkeys/khotkeys-3.5.13.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gentoo/trinity-base/khotkeys/khotkeys-3.5.13.2.ebuild b/gentoo/trinity-base/khotkeys/khotkeys-3.5.13.2.ebuild
new file mode 100644
index 000000000..e469535a8
--- /dev/null
+++ b/gentoo/trinity-base/khotkeys/khotkeys-3.5.13.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="Trinity hotkey daemon"
+KEYWORDS="~amd64 ~x86"
+IUSE="arts"
+
+DEPEND="
+ arts? ( >=trinity-base/arts-${PV}:${SLOT} )
+ x11-libs/libXtst"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ mycmakeargs=(
+ -D_WITH_XTEST=ON
+ $(cmake-utils_use_with arts ARTS)
+ )
+
+ trinity-meta_src_configure
+}