summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kicker/kicker-3.5.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/kicker/kicker-3.5.13.1.ebuild')
-rw-r--r--gentoo/trinity-base/kicker/kicker-3.5.13.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kicker/kicker-3.5.13.1.ebuild b/gentoo/trinity-base/kicker/kicker-3.5.13.1.ebuild
new file mode 100644
index 000000000..7d6e40d1f
--- /dev/null
+++ b/gentoo/trinity-base/kicker/kicker-3.5.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The Trinity application starter panel, capable of applets and extensions"
+KEYWORDS="x86 amd64"
+IUSE="xcomposite"
+
+DEPEND=">=trinity-base/libkonq-${PV}:${SLOT}
+ >=trinity-base/kdebase-data-${PV}:${SLOT}
+ xcomposite? ( x11-libs/libXrender )
+ xcomposite? ( x11-libs/libXfixes )
+ xcomposite? ( x11-libs/libXcomposite )"
+
+RDEPEND="${DEPEND}
+ trinity-base/kmenuedit:${SLOT}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xcomposite XFIXES)
+ $(cmake-utils_use_with xcomposite XRENDER)
+ $(cmake-utils_use_with xcomposite XCOMPOSITE)
+ )
+
+ trinity-meta_src_configure
+}