summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild')
-rw-r--r--gentoo/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gentoo/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild b/gentoo/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
new file mode 100644
index 000000000..fc6ee6bfd
--- /dev/null
+++ b/gentoo/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdeutils"
+
+inherit trinity-meta
+
+DESCRIPTION="KLaptopdaemon - Trinity battery monitoring and management for laptops."
+KEYWORDS=""
+IUSE="xscreensaver"
+
+DEPEND="x11-libs/libXtst
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ virtual/os-headers"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ "-DWITH_DPMS=ON"
+ $(cmake-utils_use_with xscreensaver XSCREENSAVER)
+ )
+
+ trinity-meta_src_configure
+}