summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/ksplashml/ksplashml-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/ksplashml/ksplashml-9999.ebuild')
-rw-r--r--gentoo/trinity-base/ksplashml/ksplashml-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/gentoo/trinity-base/ksplashml/ksplashml-9999.ebuild b/gentoo/trinity-base/ksplashml/ksplashml-9999.ebuild
new file mode 100644
index 000000000..d67ec25c3
--- /dev/null
+++ b/gentoo/trinity-base/ksplashml/ksplashml-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="Trinity splashscreen framework (of Trinity itself, not of individual apps)"
+KEYWORDS=
+IUSE="xinerama"
+
+DEPEND="x11-libs/libXcursor
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xinerama XINERAMA)
+ )
+
+ trinity-meta_src_configure
+}