summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/tde-i18n/tde-i18n-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/tde-i18n/tde-i18n-9999.ebuild')
-rw-r--r--gentoo/trinity-base/tde-i18n/tde-i18n-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/gentoo/trinity-base/tde-i18n/tde-i18n-9999.ebuild b/gentoo/trinity-base/tde-i18n/tde-i18n-9999.ebuild
new file mode 100644
index 000000000..53f4a81f5
--- /dev/null
+++ b/gentoo/trinity-base/tde-i18n/tde-i18n-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tde-i18n"
+
+inherit trinity-base cmake-utils l10n
+
+set-trinityver
+
+DESCRIPTION="Trinity internationalization package"
+HOMEPAGE="http://www.trinitydesktop.org/"
+LICENSE="GPL-2"
+
+SLOT="${TRINITY_VER}"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=trinity-base/tdelibs-${PV}:${SLOT}"
+RDEPEND="${DEPEND}"
+
+PLOCALES="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et
+eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms
+nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta te
+tg th tr uk uz uz@cyrillic vi wa zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+run_phase() {
+ local lang dir phase;
+ phase=$1
+ lang=$2
+
+ dir="tde-i18n-$lang"
+ pushd "$S/$dir" || die "No such dir: $dir"
+ CMAKE_USE_DIR="${S}/${dir}"
+ BUILD_DIR="${WORKDIR}/${dir}-build"
+ trinity-base_${phase}
+ popd
+}
+
+src_prepare() {
+ l10n_find_plocales_changes "${S}" "${PN}-" ""
+ l10n_for_each_locale_do run_phase src_prepare
+}
+
+src_configure() {
+ mycmakeargs=( -DBUILD_ALL=ON )
+ l10n_for_each_locale_do run_phase src_configure
+}
+
+src_compile() {
+ l10n_for_each_locale_do run_phase src_compile
+}
+
+src_install() {
+ l10n_for_each_locale_do run_phase src_install
+}