summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/twin/twin-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/twin/twin-9999.ebuild')
m---------gentoo0
-rw-r--r--gentoo/trinity-base/twin/twin-9999.ebuild47
2 files changed, 0 insertions, 47 deletions
diff --git a/gentoo b/gentoo
new file mode 160000
+Subproject 644110a847c5911c2eb04eb53c93031740561ef
diff --git a/gentoo/trinity-base/twin/twin-9999.ebuild b/gentoo/trinity-base/twin/twin-9999.ebuild
deleted file mode 100644
index 927a0e5ea..000000000
--- a/gentoo/trinity-base/twin/twin-9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-TRINITY_MODULE_NAME="tdebase"
-
-inherit trinity-meta eutils
-
-DESCRIPTION="Trinity window manager"
-KEYWORDS=
-IUSE="xcomposite xrandr xinerama +libconfig +pcre opengl"
-
-DEPEND="x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrender
- xcomposite? ( x11-libs/libXcomposite )
- xinerama? ( x11-proto/xineramaproto )
- xrandr? ( x11-libs/libXrandr )
- libconfig? ( dev-libs/libconfig )
- opengl? ( virtual/opengl )
- pcre? ( dev-libs/libpcre[jit] )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with xcomposite XCOMPOSITE)
- $(cmake-utils_use_with xcomposite XFIXES)
- $(cmake-utils_use_with xcomposite XRENDER)
- $(cmake-utils_use_with xrandr XRANDR)
- $(cmake-utils_use_with libconfig LIBCONFIG)
- $(cmake-utils_use_with pcre PCRE)
- $(cmake-utils_use_with xinerama XINERAMA)
- )
-
- trinity-meta_src_configure
-}
-
-pkg_postinst() {
- if ! use xcomposite; then
- for flag in xrandr xinerama libconfig pcre opengl; do
- use $flag && \
- ewarn "USE=\"$flag\" is passed, but it doesn't change anything due to" && \
- ewarn "$flag support in ${P} take effect only if composite is enabled."
- done
-
- fi
-}