summaryrefslogtreecommitdiffstats
path: root/redhat/applications/gwenview-i18n/gwenview-i18n.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/gwenview-i18n/gwenview-i18n.spec')
-rw-r--r--redhat/applications/gwenview-i18n/gwenview-i18n.spec168
1 files changed, 168 insertions, 0 deletions
diff --git a/redhat/applications/gwenview-i18n/gwenview-i18n.spec b/redhat/applications/gwenview-i18n/gwenview-i18n.spec
new file mode 100644
index 000000000..59bbfaa5b
--- /dev/null
+++ b/redhat/applications/gwenview-i18n/gwenview-i18n.spec
@@ -0,0 +1,168 @@
+#
+# spec file for package gwenview-i18n (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.0
+%endif
+%define tde_pkg gwenview-i18n
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.4.2
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Internationalization support for Gwenview [Trinity]
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: gettext
+
+BuildRequires: cmake
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+
+%description
+Gwenview is a fast and easy to use image viewer/browser for TDE.
+All common image formats are supported, such as PNG(including transparency),
+JPEG(including EXIF tags and lossless transformations), GIF, XCF (Gimp
+image format), BMP, XPM and others. Standard features include slideshow,
+fullscreen view, image thumbnails, drag'n'drop, image zoom, full network
+transparency using the KIO framework, including basic file operations and
+browsing in compressed archives, non-blocking GUI with adjustable views.
+Gwenview also provides image and directory KParts components for use e.g. in
+Konqueror. Additional features, such as image renaming, comparing,
+converting, and batch processing, HTML gallery and others are provided by the
+KIPI image framework.
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ \
+ -DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
+ -DBIN_INSTALL_DIR="%{tde_bindir}" \
+ -DINCLUDE_INSTALL_DIR="%{tde_tdeincludedir}" \
+ -DLIB_INSTALL_DIR="%{tde_libdir}" \
+ -DPKGCONFIG_INSTALL_DIR="%{tde_libdir}/pkgconfig" \
+ -DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
+ \
+ -DBUILD_ALL=ON \
+ -DBUILD_DOC=ON \
+ -DBUILD_TRANSLATIONS=ON \
+ ..
+
+%__make %{?_smp_mflags}
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
+
+## File lists
+%find_lang gwenview
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files -f gwenview.lang
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog COPYING TODO
+%lang(da) %{tde_tdedocdir}/HTML/da/gwenview/
+%lang(de) %{tde_tdedocdir}/HTML/de/gwenview/
+%lang(et) %{tde_tdedocdir}/HTML/et/gwenview/
+%lang(fr) %{tde_tdedocdir}/HTML/fr/gwenview/
+%lang(it) %{tde_tdedocdir}/HTML/it/gwenview/
+%lang(nl) %{tde_tdedocdir}/HTML/nl/gwenview/
+%lang(pl) %{tde_tdedocdir}/HTML/pl/gwenview/
+%lang(pt) %{tde_tdedocdir}/HTML/pt/gwenview/
+%lang(pt_BR) %{tde_tdedocdir}/HTML/pt_BR/gwenview/
+%lang(ru) %{tde_tdedocdir}/HTML/ru/gwenview/
+%lang(sv) %{tde_tdedocdir}/HTML/sv/gwenview/
+
+
+%changelog