summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kbfx/kbfx-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kbfx/kbfx-14.0.0.spec')
-rw-r--r--redhat/applications/kbfx/kbfx-14.0.0.spec12
1 files changed, 6 insertions, 6 deletions
diff --git a/redhat/applications/kbfx/kbfx-14.0.0.spec b/redhat/applications/kbfx/kbfx-14.0.0.spec
index 8661e7e81..6721d1cc6 100644
--- a/redhat/applications/kbfx/kbfx-14.0.0.spec
+++ b/redhat/applications/kbfx/kbfx-14.0.0.spec
@@ -82,14 +82,13 @@ export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
# Shitty hack for RHEL4 ...
if [ -d "/usr/X11R6" ]; then
export CMAKE_INCLUDE_PATH="${CMAKE_INCLUDE_PATH}:/usr/X11R6/include:/usr/X11R6/%{_lib}"
- export CFLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
- export CXXFLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
+ export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
-%if 0%{?rhel} || 0%{?fedora} || 0%{?suse_version}
-%__mkdir_p build
-cd build
-%endif
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
%cmake \
-DCMAKE_BUILD_TYPE="RelWithDebInfo" \
@@ -111,6 +110,7 @@ cd build
\
-DUSE_STRIGI=OFF \
-DUSE_MENUDRAKE=OFF \
+ -DBUILD_DOC=ON \
-DBUILD_ALL=ON \
..