summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kompose/kompose.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kompose/kompose.spec')
-rw-r--r--redhat/applications/kompose/kompose.spec156
1 files changed, 0 insertions, 156 deletions
diff --git a/redhat/applications/kompose/kompose.spec b/redhat/applications/kompose/kompose.spec
deleted file mode 100644
index 543b695ec..000000000
--- a/redhat/applications/kompose/kompose.spec
+++ /dev/null
@@ -1,156 +0,0 @@
-#
-# spec file for package kompose (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.0.9
-%endif
-%define tde_pkg kompose
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-%define tde_tdeappdir %{tde_appdir}/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Summary: Full-Screen Task Manager for TDE
-Version: 0.5.3
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-
-License: GPLv2+
-Group: Applications/Utilities
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
-
-Prefix: %{_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: cmake
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: desktop-file-utils
-
-BuildRequires: gettext
-
-# IMLIB2 support
-BuildRequires: imlib2-devel
-
-# XCOMPOSITE support
-%if 0%{?mgaversion} || 0%{?mdkversion}
-%if 0%{?mgaversion} >= 4
-%define xcomposite_devel %{_lib}xcomposite-devel
-%else
-%define xcomposite_devel %{_lib}xcomposite%{?mgaversion:1}-devel
-%endif
-%endif
-%if 0%{?rhel} >= 5 || 0%{?fedora} || 0%{?suse_version} >= 1220
-%define xcomposite_devel libXcomposite-devel
-%endif
-%{?xcomposite_devel:BuildRequires: %{xcomposite_devel}}
-
-# XDAMAGE support
-%if 0%{?mgaversion} || 0%{?mdkversion}
-BuildRequires: %{_lib}xdamage-devel
-%endif
-%if 0%{?rhel} >= 5 || 0%{?fedora} || 0%{?suse_version} >= 1220
-BuildRequires: libXdamage-devel
-%endif
-
-
-%description
-Kompose creates a full-screen view in which every window is represented
-by a scaled screen shot of it. It appears as a panel applet.
-
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-
-if ! rpm -E %%cmake|grep -q "cd build"; then
- %__mkdir_p build
- cd build
-fi
-
-%cmake \
- -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
- -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_SKIP_RPATH=OFF \
- -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DWITH_GCC_VISIBILITY=OFF \
- \
- -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
- -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
- -DLIB_INSTALL_DIR=%{tde_libdir} \
- -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
- \
- -DWITH_ALL_OPTIONS=ON \
- -DBUILD_ALL=ON \
- ..
-
-%__make %{?_smp_mflags} || %__make
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot} -C build
-
-%find_lang %{tde_pkg}
-
-
-%clean
-%__rm -rf %{buildroot}
-
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%doc README AUTHORS ChangeLog COPYING
-%{tde_bindir}/kompose
-%{tde_tdeappdir}/kompose.desktop
-%{tde_datadir}/apps/kompose/
-%{tde_tdedocdir}/HTML/en/kompose/
-%{tde_datadir}/icons/hicolor/16x16/apps/kompose.png
-%{tde_datadir}/icons/hicolor/32x32/apps/kompose.png
-
-
-%changelog