summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kooldock/kooldock.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kooldock/kooldock.spec')
-rw-r--r--redhat/applications/kooldock/kooldock.spec173
1 files changed, 0 insertions, 173 deletions
diff --git a/redhat/applications/kooldock/kooldock.spec b/redhat/applications/kooldock/kooldock.spec
deleted file mode 100644
index b2634aaf6..000000000
--- a/redhat/applications/kooldock/kooldock.spec
+++ /dev/null
@@ -1,173 +0,0 @@
-#
-# spec file for package kooldock (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
-%endif
-%define tde_pkg kooldock
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_confdir %{_sysconfdir}/trinity
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_tdeappdir %{tde_datadir}/applications/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Epoch: %{tde_epoch}
-Version: 0.4.7
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-Summary: Dock for TDE with cool visual enhancements
-Group: Applications/Utilities
-URL: http://www.trinitydesktop.org/
-
-%if 0%{?suse_version}
-License: GPL-2.0+
-%else
-License: GPLv2+
-%endif
-
-#Vendor: Trinity Desktop
-#Packager: Francois Andriot <francois.andriot@free.fr>
-
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-
-BuildRequires: desktop-file-utils
-
-BuildRequires: cmake >= 2.8
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig
-BuildRequires: libtool
-
-# IDN support
-BuildRequires: libidn-devel
-
-# ACL support
-BuildRequires: libacl-devel
-
-# OPENSSL support
-BuildRequires: openssl-devel
-
-# SUSE desktop files utility
-%if 0%{?suse_version}
-BuildRequires: update-desktop-files
-%endif
-
-%if 0%{?opensuse_bs} && 0%{?suse_version}
-# for xdg-menu script
-BuildRequires: brp-check-trinity
-%endif
-
-
-%description
-KoolDock is a fork of the original work of Dang Viet Dung,.
-KSmoothDock 2.1. KoolDock is a dock for TDE with cool.
-visual enhancements and effects.
-
-Some of it features are:
-* Display quick launchers to your favourite apps
-* A builtin task bar
-* Pager and clock. (Not done yet)
-* Smooth zooming effect (like Apple's OS X dock)
-* Transparent Background
-
-Homepage: http://sourceforge.net/projects/kooldock/
-
-##########
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-##########
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-
-if ! rpm -E %%cmake|grep -q "cd build"; then
- %__mkdir_p build
- cd build
-fi
-
-%cmake \
- -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
- -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_SKIP_RPATH=OFF \
- -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DWITH_GCC_VISIBILITY=OFF \
- \
- -DCMAKE_INSTALL_PREFIX="%{tde_prefix}" \
- -DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
- -DLIB_INSTALL_DIR="%{tde_libdir}" \
- \
- -DWITH_ALL_OPTIONS=ON \
- -DWITH_GCC_VISIBILITY=ON \
- \
- -DBUILD_ALL=ON \
- -DBUILD_DOC=ON \
- -DBUILD_TRANSLATIONS=ON \
- ..
-
-%__make %{?_smp_mflags} || %__make
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot} -C build
-
-%find_lang %{tde_pkg}
-
-
-%clean
-%__rm -rf %{buildroot}
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%doc AUTHORS ChangeLog COPYING README TODO
-%{tde_bindir}/kooldock
-%{tde_datadir}/apps/kooldock/
-%{tde_datadir}/icons/crystalsvg/16x16/apps/kooldock.png
-%{tde_datadir}/icons/crystalsvg/32x32/apps/kooldock.png
-%{tde_datadir}/icons/crystalsvg/64x64/apps/kooldock.png
-%{tde_datadir}/icons/crystalsvg/128x128/apps/kooldock.png
-
-
-%changelog