summaryrefslogtreecommitdiffstats
path: root/redhat/applications/system/klamav/klamav.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/system/klamav/klamav.spec')
-rw-r--r--redhat/applications/system/klamav/klamav.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/redhat/applications/system/klamav/klamav.spec b/redhat/applications/system/klamav/klamav.spec
index 015eaa364..4b892dcf1 100644
--- a/redhat/applications/system/klamav/klamav.spec
+++ b/redhat/applications/system/klamav/klamav.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg klamav
%define tde_prefix /opt/trinity
@@ -67,7 +67,14 @@ BuildRequires: desktop-file-utils
BuildRequires: gettext
BuildRequires: curl-devel
BuildRequires: gmp-devel
-BuildRequires: sqlite-devel
+
+# SQLITE3 support
+%if 0%{?mgaversion}
+BuildRequires: sqlite3-devel
+%else
+BuildRequires: sqlite-devel
+%endif
+
#BuildRequires: unsermake
# CLAMAV support
@@ -76,7 +83,11 @@ BuildRequires: clamav-devel
Requires: clamav
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
%description
@@ -95,7 +106,7 @@ A TDE front-end for the Clam AntiVirus antivirus toolkit.
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi