summaryrefslogtreecommitdiffstats
path: root/redhat/applications/wlassistant/wlassistant.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/wlassistant/wlassistant.spec')
-rw-r--r--redhat/applications/wlassistant/wlassistant.spec203
1 files changed, 0 insertions, 203 deletions
diff --git a/redhat/applications/wlassistant/wlassistant.spec b/redhat/applications/wlassistant/wlassistant.spec
deleted file mode 100644
index 823f48b66..000000000
--- a/redhat/applications/wlassistant/wlassistant.spec
+++ /dev/null
@@ -1,203 +0,0 @@
-#
-# spec file for package wlassistant (version R14)
-#
-# Copyright (c) 2014 Trinity Desktop Environment
-#
-# All modifications and additions to the file contributed by third parties
-# remain the property of their copyright owners, unless otherwise agreed
-# upon. The license for this file, and modifications and additions to the
-# file, is the same license as for the pristine package itself (unless the
-# license for the pristine package is not an Open Source License, in which
-# case the license is the MIT License). An "Open Source License" is a
-# license that conforms to the Open Source Definition (Version 1.9)
-# published by the Open Source Initiative.
-#
-# Please submit bugfixes or comments via http://www.trinitydesktop.org/
-#
-
-# TDE variables
-%define tde_epoch 2
-%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
-%endif
-%define tde_pkg wlassistant
-%define tde_prefix /opt/trinity
-%define tde_bindir %{tde_prefix}/bin
-%define tde_datadir %{tde_prefix}/share
-%define tde_docdir %{tde_datadir}/doc
-%define tde_includedir %{tde_prefix}/include
-%define tde_libdir %{tde_prefix}/%{_lib}
-%define tde_mandir %{tde_datadir}/man
-%define tde_tdeappdir %{tde_datadir}/applications/tde
-%define tde_tdedocdir %{tde_docdir}/tde
-%define tde_tdeincludedir %{tde_includedir}/tde
-%define tde_tdelibdir %{tde_libdir}/trinity
-
-
-Name: trinity-%{tde_pkg}
-Epoch: %{tde_epoch}
-Version: 0.5.7
-Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
-Summary: User friendly TDE frontend for wireless network connection
-Group: Applications/Utilities
-URL: http://wlassistant.sourceforge.net/
-
-%if 0%{?suse_version}
-License: GPL-2.0+
-%else
-License: GPLv2+
-%endif
-
-#Vendor: Trinity Desktop
-#Packager: Francois Andriot <francois.andriot@free.fr>
-
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: desktop-file-utils
-BuildRequires: gettext
-
-BuildRequires: trinity-cmake >= %{tde_version}
-BuildRequires: libtool
-BuildRequires: gcc-c++
-BuildRequires: pkgconfig
-BuildRequires: fdupes
-
-# SUSE desktop files utility
-%if 0%{?suse_version}
-BuildRequires: update-desktop-files
-%endif
-
-%if 0%{?opensuse_bs} && 0%{?suse_version}
-# for xdg-menu script
-BuildRequires: brp-check-trinity
-%endif
-
-# Wireless support
-%if 0%{?fedora} >= 6 || 0%{?rhel} >= 5
-BuildRequires: wireless-tools-devel
-%endif
-%if 0%{?mgaversion} == 2 || 0%{?mdkversion}
-BuildRequires: %{_lib}iw29-devel
-%endif
-%if 0%{?rhel} == 5 || 0%{?suse_version}
-BuildRequires: wireless-tools
-%endif
-%if 0%{?suse_version} || 0%{?mgaversion} >= 3
-BuildRequires: libiw-devel
-%endif
-
-# IDN support
-BuildRequires: libidn-devel
-
-# GAMIN support
-# Not on openSUSE.
-%if 0%{?rhel} || ( 0%{?fedora} && 0%{?fedora} <= 33 ) || 0%{?mgaversion} || 0%{?mdkversion}
-%define with_gamin 1
-BuildRequires: gamin-devel
-%endif
-
-# PYTHON support
-%if 0%{?sle_version} >= 150400
-%define python python3
-%define __python %__python3
-%else
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
-%global python python2
-%global __python %__python2
-%global python_sitearch %{python2_sitearch}
-%else
-%global python python
-%endif
-%endif
-%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-BuildRequires: %{python}
-BuildRequires: %{python}-devel
-
-# OPENSSL support
-BuildRequires: openssl-devel
-
-
-%description
-Wireless Assistant scans for wireless access points and displays link quality,
-encryption and other useful information. When user wants to connect to a
-network, Wireless Assistant opens up its wizards and guides the user through
-Wi-Fi settings. After a successful connection is made the settings are
-remembered so next time the user won't have to enter them again.
-
-##########
-
-%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
-%debug_package
-%endif
-
-##########
-
-%prep
-%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-
-
-%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-
-# Shitty hack for RHEL4 ...
-if [ -d "/usr/X11R6" ]; then
- export CMAKE_INCLUDE_PATH="${CMAKE_INCLUDE_PATH}:/usr/X11R6/include:/usr/X11R6/%{_lib}"
- export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
-fi
-
-if ! rpm -E %%cmake|grep -q "cd build"; then
- %__mkdir_p build
- cd build
-fi
-
-%cmake \
- -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
- -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
- -DCMAKE_SKIP_RPATH=OFF \
- -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- -DWITH_GCC_VISIBILITY=OFF \
- \
- -DBIN_INSTALL_DIR=%{tde_bindir} \
- -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
- -DLIB_INSTALL_DIR=%{tde_libdir} \
- -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
- \
- -DBUILD_ALL=ON \
- ..
-
-%__make %{?_smp_mflags}
-
-
-%install
-export PATH="%{tde_bindir}:${PATH}"
-%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot} -C build
-
-# Updates applications categories for openSUSE
-%if 0%{?suse_version}
-%suse_update_desktop_file -i -r "%{?buildroot}%{tde_tdeappdir}/wlassistant.desktop" System Network
-%endif
-
-%find_lang %{tde_pkg}
-
-
-%clean
-%__rm -rf %{buildroot}
-
-
-%files -f %{tde_pkg}.lang
-%defattr(-,root,root,-)
-%doc ChangeLog VERSION
-%{tde_bindir}/wlassistant
-%{tde_tdeappdir}/wlassistant.desktop
-%{tde_datadir}/icons/hicolor/16x16/apps/wlassistant.png
-%{tde_datadir}/icons/hicolor/32x32/apps/wlassistant.png