summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec')
-rw-r--r--redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec200
1 files changed, 139 insertions, 61 deletions
diff --git a/redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec b/redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec
index 3f28a0b96..783b2adfd 100644
--- a/redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec
+++ b/redhat/main/tdeaccessibility/tdeaccessibility-3.5.13.2.spec
@@ -1,56 +1,98 @@
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
+#
+# spec file for package tdeaccessibility (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# BUILD WARNING:
+# Remove qt-devel and qt3-devel and any kde*-devel on your system !
+# Having KDE libraries may cause FTBFS here !
+
+# TDE variables
+%define tde_epoch 1
%define tde_version 3.5.13.2
-
-# TDE specific building variables
+%define tde_pkg tdeaccessibility
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
-
%define tde_tdeappdir %{tde_datadir}/applications/kde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
-Summary: Trinity Desktop Environment - Accessibility
Name: trinity-tdeaccessibility
+Summary: Trinity Desktop Environment - Accessibility
Version: %{tde_version}
-Release: %{?!preversion:2}%{?preversion:1_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2
-Group: User Interface/Desktops
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
+Release: %{?!preversion:3}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Group: System/GUI/Other
URL: http://www.trinitydesktop.org/
-Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Project
+#Packager: Francois Andriot <francois.andriot@free.fr>
Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: autoconf automake libtool m4
-BuildRequires: desktop-file-utils
-BuildRequires: trinity-akode-devel
-BuildRequires: trinity-arts-devel >= 1:1.5.10
+Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-arts-devel >= %{tde_epoch}:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: trinity-tdemultimedia-devel >= %{tde_version}
-BuildRequires: alsa-lib-devel
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: desktop-file-utils
+BuildRequires: fdupes
-# X11 Libraries
-%if 0%{?fedora} > 4 || 0%{?rhel} > 4
-BuildRequires: libXtst-devel
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
%endif
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# AUDIOFILE support
+BuildRequires: audiofile-devel
+
+# AKODE support
+%if 0%{?with_akode}
+BuildRequires: trinity-akode-devel
+%{?with_mad:BuildRequires: trinity-akode-libmad}
+%endif
+
+# ALSA support
+BuildRequires: alsa-lib-devel
+
# XCB support
%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?pclinuxos}
BuildRequires: libxcb-devel
@@ -61,35 +103,24 @@ BuildRequires: %{_lib}xcb-devel
%endif
%endif
-# X11 stuff
+# XAU support
%if 0%{?mgaversion} || 0%{?mdkversion}
-BuildRequires: %{_lib}xi-devel
%if 0%{?mgaversion} >= 4
-BuildRequires: %{_lib}xext-devel
-BuildRequires: %{_lib}x11-devel
BuildRequires: %{_lib}xau-devel
%else
-BuildRequires: %{_lib}xext%{?mgaversion:6}-devel
-BuildRequires: %{_lib}x11%{?mgaversion:_6}-devel
BuildRequires: %{_lib}xau%{?mgaversion:6}-devel
%endif
%endif
%if 0%{?rhel} >= 5 || 0%{?fedora} || 0%{?suse_version} >= 1220
-BuildRequires: libXi-devel
-BuildRequires: libXext-devel
-BuildRequires: libX11-devel
BuildRequires: libXau-devel
%endif
-%if 0%{?rhel} == 4 || 0%{?suse_version} == 1140
-BuildRequires: xorg-x11-devel
-%endif
Obsoletes: trinity-kdeaccessibility < %{version}-%{release}
Provides: trinity-kdeaccessibility = %{version}-%{release}
Obsoletes: trinity-kdeaccessibility-libs < %{version}-%{release}
Provides: trinity-kdeaccessibility-libs = %{version}-%{release}
-Requires: trinity-kde-icons-mono = %{version}-%{release}
+Requires: trinity-tde-icons-mono = %{version}-%{release}
Requires: trinity-kbstate = %{version}-%{release}
Requires: trinity-kmag = %{version}-%{release}
Requires: trinity-kmousetool = %{version}-%{release}
@@ -111,7 +142,7 @@ Included with this package are:
%package -n trinity-tde-icons-mono
Summary: A monochromatic icons theme for TDE
-Group: User Interface/Desktops
+Group: System/GUI/Other
Obsoletes: trinity-kde-icons-mono < %{version}-%{release}
Provides: trinity-kde-icons-mono = %{version}-%{release}
@@ -123,14 +154,21 @@ This package is part of Trinity, as a component of the TDE accessibility module.
%files -n trinity-tde-icons-mono
%defattr(-,root,root,-)
+%dir %{tde_datadir}/icons/mono
+%dir %{tde_datadir}/icons/mono/scalable
+%dir %{tde_datadir}/icons/mono/scalable/actions
+%dir %{tde_datadir}/icons/mono/scalable/apps
+%dir %{tde_datadir}/icons/mono/scalable/devices
+%dir %{tde_datadir}/icons/mono/scalable/filesystems
+%dir %{tde_datadir}/icons/mono/scalable/mimetypes
%{tde_datadir}/icons/mono/index.theme
%{tde_datadir}/icons/mono/scalable/*/*.svgz
##########
%package -n trinity-kbstate
-Summary: a keyboard status applet for TDE
-Group: User Interface/Desktops
+Summary: A keyboard status applet for TDE
+Group: System/GUI/Other
%description -n trinity-kbstate
A panel applet that displays the keyboard status.
@@ -148,7 +186,7 @@ This package is part of Trinity, as a component of the TDE accessibility module.
%package -n trinity-kmag
Summary: A screen magnifier for TDE
-Group: User Interface/Desktops
+Group: System/GUI/Other
%description -n trinity-kmag
TDE's screen magnifier tool.
@@ -163,7 +201,7 @@ This package is part of Trinity, as a component of the TDE accessibility module.
%files -n trinity-kmag
%defattr(-,root,root,-)
%{tde_bindir}/kmag
-%{tde_datadir}/applnk/Applications/kmag.desktop
+%{tde_tdeappdir}/kmag.desktop
%{tde_datadir}/apps/kmag/
%{tde_datadir}/icons/hicolor/*/apps/kmag.png
%{tde_datadir}/icons/locolor/*/apps/kmag.png
@@ -187,7 +225,7 @@ done
%package -n trinity-kmousetool
Summary: TDE mouse manipulation tool for the disabled
-Group: User Interface/Desktops
+Group: System/GUI/Other
%description -n trinity-kmousetool
KMouseTool clicks the mouse whenever the mouse cursor pauses briefly. It was
@@ -199,7 +237,7 @@ This package is part of Trinity, as a component of the TDE accessibility module.
%files -n trinity-kmousetool
%defattr(-,root,root,-)
%{tde_bindir}/kmousetool
-%{tde_datadir}/applnk/Applications/kmousetool.desktop
+%{tde_tdeappdir}/kmousetool.desktop
%{tde_datadir}/apps/kmousetool/
%{tde_datadir}/icons/hicolor/*/apps/kmousetool.png
%{tde_tdedocdir}/HTML/en/kmousetool/
@@ -220,7 +258,7 @@ done
%package -n trinity-kmouth
Summary: A type-and-say KDE frontend for speech synthesizers
-Group: User Interface/Desktops
+Group: System/GUI/Other
%description -n trinity-kmouth
KDE's type-and-say frontend for speech synthesizers.
@@ -234,7 +272,7 @@ This package is part of Trinity, as a component of the TDE accessibility module.
%defattr(-,root,root,-)
%{tde_datadir}/config/kmouthrc
%{tde_bindir}/kmouth
-%{tde_datadir}/applnk/Applications/kmouth.desktop
+%{tde_tdeappdir}/kmouth.desktop
%{tde_datadir}/apps/kmouth/
%{tde_datadir}/icons/hicolor/*/actions/speak.png
%{tde_datadir}/icons/hicolor/*/actions/nospeak.png
@@ -259,7 +297,7 @@ done
%package -n trinity-ksayit
Summary: A frontend for the TDE Text-to-Speech system
-Group: User Interface/Desktops
+Group: System/GUI/Other
%description -n trinity-ksayit
Text-to-speech front-end to kttsd.
@@ -269,7 +307,6 @@ This package is part of Trinity, as a component of the TDE accessibility module.
%files -n trinity-ksayit
%defattr(-,root,root,-)
%{tde_bindir}/ksayit
-%{tde_tdeincludedir}/ksayit_fxplugin.h
%{tde_tdelibdir}/libFreeverb_plugin.la
%{tde_tdelibdir}/libFreeverb_plugin.so
%{tde_libdir}/libKTTSD_Lib.so.*
@@ -301,7 +338,7 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%package -n trinity-kttsd
Summary: A Text-to-Speech system for TDE
-Group: User Interface/Desktops
+Group: System/GUI/Other
%description -n trinity-kttsd
The KDE Text-to-Speech system is a plugin based service that allows any KDE
@@ -322,8 +359,10 @@ Homepage: http://accessibility.kde.org/developer/kttsd
%{tde_tdelibdir}/kcm_kttsd.so
%{tde_tdelibdir}/ktexteditor_kttsd.la
%{tde_tdelibdir}/ktexteditor_kttsd.so
+%if 0%{?with_akode}
%{tde_tdelibdir}/libkttsd_akodeplugin.la
%{tde_tdelibdir}/libkttsd_akodeplugin.so
+%endif
%{tde_tdelibdir}/libkttsd_alsaplugin.la
%{tde_tdelibdir}/libkttsd_alsaplugin.so
%{tde_tdelibdir}/libkttsd_artsplugin.la
@@ -349,14 +388,18 @@ Homepage: http://accessibility.kde.org/developer/kttsd
%{tde_libdir}/libkttsd.so.*
%{tde_tdeappdir}/kcmkttsd.desktop
%{tde_tdeappdir}/kttsmgr.desktop
-%{tde_datadir}/apps/ktexteditor_kttsd/ktexteditor_kttsdui.rc
+%{tde_datadir}/apps/ktexteditor_kttsd/
%exclude %{tde_datadir}/apps/kttsd/hadifix/xslt/SSMLtoTxt2pho.xsl
%{tde_datadir}/apps/kttsd/
%{tde_datadir}/icons/hicolor/16x16/actions/female.png
%{tde_datadir}/icons/hicolor/16x16/actions/male.png
+%{tde_datadir}/icons/hicolor/*/apps/kttsd.png
+%{tde_datadir}/icons/hicolor/*/apps/kcmkttsd.png
%{tde_datadir}/services/ktexteditor_kttsd.desktop
%{tde_datadir}/services/kttsd.desktop
+%if 0%{?with_akode}
%{tde_datadir}/services/kttsd_akodeplugin.desktop
+%endif
%{tde_datadir}/services/kttsd_alsaplugin.desktop
%{tde_datadir}/services/kttsd_artsplugin.desktop
%{tde_datadir}/services/kttsd_commandplugin.desktop
@@ -371,8 +414,6 @@ Homepage: http://accessibility.kde.org/developer/kttsd
%{tde_datadir}/servicetypes/kttsd_audioplugin.desktop
%{tde_datadir}/servicetypes/kttsd_filterplugin.desktop
%{tde_datadir}/servicetypes/kttsd_synthplugin.desktop
-%{tde_datadir}/icons/crystalsvg/*/apps/kttsd.png
-%{tde_datadir}/icons/crystalsvg/*/apps/kttsd.svgz
%{tde_tdedocdir}/HTML/en/kttsd/
%post -n trinity-kttsd
@@ -394,8 +435,8 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
##########
%package -n trinity-kttsd-contrib-plugins
-Summary: the TDE Text-to-Speech system
-Group: User Interface/Desktops
+Summary: The TDE Text-to-Speech system
+Group: System/GUI/Other
Requires: trinity-kttsd = %{version}-%{release}
%description -n trinity-kttsd-contrib-plugins
@@ -420,16 +461,19 @@ This package is part of Trinity, as a component of the TDE accessibility module.
##########
%package devel
-Summary: Development files for %{name}
-Group: Development/Libraries
+Summary: Development files for tdeaccessibility
+Group: Development/Libraries/X11
Requires: %{name} = %{version}-%{release}
Requires: trinity-tdelibs-devel >= %{version}
+Requires: libjpeg-devel
+Requires: libpng-devel
Obsoletes: trinity-kdeaccessibility-devel < %{version}-%{release}
Provides: trinity-kdeaccessibility-devel = %{version}-%{release}
%description devel
-%{summary}.
+This package contains the development file for TDE accessibility
+programs.
%files devel
%defattr(-,root,root,-)
@@ -437,6 +481,7 @@ Provides: trinity-kdeaccessibility-devel = %{version}-%{release}
%{tde_libdir}/libkttsd.so
%{tde_libdir}/libKTTSD_Lib.la
%{tde_libdir}/libKTTSD_Lib.so
+%{tde_tdeincludedir}/ksayit_fxplugin.h
%post devel
/sbin/ldconfig ||:
@@ -446,7 +491,7 @@ Provides: trinity-kdeaccessibility-devel = %{version}-%{release}
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
@@ -455,6 +500,9 @@ Provides: trinity-kdeaccessibility-devel = %{version}-%{release}
%prep
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
+# Update icons for some control center modules
+%__sed -i "kttsd/kcmkttsmgr/kcmkttsd.desktop" -e "s|^Icon=.*|Icon=kcmkttsd|"
+
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
@@ -492,7 +540,7 @@ fi
--enable-rpath \
\
--enable-ksayit-audio-plugins \
- --with-akode
+ %{?with_akode:--with-akode} %{?!with_akode:--without-akode}
%__make %{?_smp_mflags}
@@ -502,6 +550,36 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
%__make install DESTDIR=%{buildroot}
+# Move desktop files to correct XDG location
+%__mv -f "%{?buildroot}%{tde_datadir}/applnk/Applications/kmag.desktop" "%{?buildroot}%{tde_tdeappdir}"
+%__mv -f "%{?buildroot}%{tde_datadir}/applnk/Applications/kmousetool.desktop" "%{?buildroot}%{tde_tdeappdir}"
+%__mv -f "%{?buildroot}%{tde_datadir}/applnk/Applications/kmouth.desktop" "%{?buildroot}%{tde_tdeappdir}"
+
+# Adds missing icons in 'hicolor' theme
+# These icons are copied from 'crystalsvg' theme, provided by 'tdelibs'.
+%__mkdir_p "%{?buildroot}%{tde_datadir}/icons/hicolor/"{16x16,22x22,32x32,48x48,64x64,128x128}"/apps/"
+pushd "%{?buildroot}%{tde_datadir}/icons"
+for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/apps/kttsd.png hicolor/"$i"x"$i"/apps/kttsd.png ;done
+for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/apps/kttsd.png hicolor/"$i"x"$i"/apps/kcmkttsd.png ;done
+popd
+
+# Avoid conflict with tdelibs
+%__rm -f %{?buildroot}%{tde_datadir}/icons/crystalsvg/*/apps/kttsd.png
+%__rm -f %{?buildroot}%{tde_datadir}/icons/crystalsvg/scalable/apps/kttsd.svgz
+
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -r kmag Utility Accessibility
+%suse_update_desktop_file kmousetool Utility Accessibility
+%suse_update_desktop_file kmouth Utility Accessibility
+%suse_update_desktop_file kttsmgr Utility Accessibility
+%suse_update_desktop_file ksayit Utility Accessibility
+%suse_update_desktop_file kcmkttsd Utility Accessibility
+%endif
+
+# Links duplicate files
+%fdupes "%{?buildroot}%{tde_datadir}"
+
%clean
%__rm -rf %{buildroot}