summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdebindings/tdebindings.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdebindings/tdebindings.spec')
-rw-r--r--redhat/main/tdebindings/tdebindings.spec73
1 files changed, 51 insertions, 22 deletions
diff --git a/redhat/main/tdebindings/tdebindings.spec b/redhat/main/tdebindings/tdebindings.spec
index 883f47711..59baee29d 100644
--- a/redhat/main/tdebindings/tdebindings.spec
+++ b/redhat/main/tdebindings/tdebindings.spec
@@ -169,7 +169,11 @@ BuildRequires: Mesa-libGLU-devel
%endif
# PYTHON support
-%if 0%{?rhel} >= 7 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1500 || 0%{?mgaversion} >= 7
+%if 0%{?sle_version} >= 150400
+%define with_python 0
+%else
+%define with_python 1
+%if 0%{?rhel} >= 7 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 7
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
@@ -179,6 +183,7 @@ BuildRequires: Mesa-libGLU-devel
%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
BuildRequires: %{python}
BuildRequires: %{python}-devel
+%endif
## ruby
BuildRequires: ruby-devel >= 1.8
@@ -264,7 +269,7 @@ BuildRequires: java-1.6.0-openjdk-devel
%endif
%endif
%if 0%{?pclinuxos} == 0
-%define _with_java --with-java=%{java_home}
+%define with_java 1
%endif
## Perl
@@ -276,24 +281,24 @@ BuildRequires: perl-devel
## QScintilla
BuildRequires: libtqscintilla-devel >= %{?tde_epoch:%{tde_epoch}:}1.7.1
-%define _enable_qscintilla --enable-qscintilla
+%define with_qscintilla 1
Obsoletes: trinity-kdebindings < %{?epoch:%{epoch}:}%{version}-%{release}
Provides: trinity-kdebindings = %{?epoch:%{epoch}:}%{version}-%{release}
# Metapackage requires
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
Requires: trinity-tdebindings-java = %{?epoch:%{epoch}:}%{version}-%{release}
+Requires: trinity-juic = %{?epoch:%{epoch}:}%{version}-%{release}
%endif
Requires: trinity-libsmoketqt = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-libsmoketde = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: perl-dcop = %{?epoch:%{epoch}:}%{version}-%{release}
+%if 0%{with_python}
Requires: python-dcop = %{?epoch:%{epoch}:}%{version}-%{release}
+%endif
Requires: trinity-libkjsembed1 = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-kjscmd = %{?epoch:%{epoch}:}%{version}-%{release}
-%if "%{?_with_java}" != ""
-Requires: trinity-juic = %{?epoch:%{epoch}:}%{version}-%{release}
-%endif
Requires: trinity-libkorundum0-ruby = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-libqt0-ruby = %{?epoch:%{epoch}:}%{version}-%{release}
@@ -327,7 +332,8 @@ This package is part of the official TDE bindings module.
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libdcop3-java
Summary: DCOP bindings for Java [Trinity]
Group: System/Libraries
@@ -344,11 +350,13 @@ This package is part of the official TDE bindings module.
%files -n trinity-libdcop3-java
%defattr(-,root,root,-)
%{tde_libdir}/java/org/
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libdcop3-java-devel
Summary: DCOP bindings for Java (dcopidl2java program) [Trinity]
Group: Development/Languages/Java
@@ -365,11 +373,13 @@ This package is part of the official TDE bindings module.
%files -n trinity-libdcop3-java-devel
%defattr(-,root,root,-)
%{tde_bindir}/dcopidl2java
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libdcop3-jni
Summary: DCOP bindings for Java ( Native libraries ) [Trinity]
Group: System/Libraries
@@ -386,11 +396,13 @@ This package is part of the official TDE bindings module.
%defattr(-,root,root,-)
%{tde_libdir}/libjavadcop.la
%{tde_libdir}/libjavadcop.so
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libqt3-java
Summary: Java bindings for Qt [Trinity]
Group: System/Libraries
@@ -412,11 +424,13 @@ This package is part of the official TDE bindings module.
%defattr(-,root,root,-)
%{tde_libdir}/java/qtjava*.jar
%{tde_tdedocdir}/HTML/en/javalib/
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libtqt3-jni
Summary: Java bindings for TQt ( Native libraries ) [Trinity]
Group: System/Libraries
@@ -438,11 +452,13 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/jni/lib*qtjava.la
%{tde_libdir}/jni/lib*qtjava.so.*
%doc qtjava/ChangeLog
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libtqt3-jni-devel
Summary: Development files fo Java bindings for TQt ( Native libraries ) [Trinity]
Group: Development/Languages/Java
@@ -460,11 +476,13 @@ This package is part of the official TDE bindings module.
%defattr(-,root,root,-)
%{tde_libdir}/lib*qtjavasupport.so
%{tde_libdir}/jni/lib*qtjava.so
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libtrinity-java
Summary: Tdelibs bindings for Java [Trinity]
Group: System/Libraries
@@ -484,11 +502,13 @@ This package is part of the official TDE bindings module.
%files -n trinity-libtrinity-java
%defattr(-,root,root,-)
%{tde_libdir}/java/koala*.jar
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libtrinity-jni
Summary: Tdelibs bindings for java ( Native libraries ) [Trinity]
Group: System/Libraries
@@ -505,11 +525,13 @@ This package is part of the official TDE bindings module.
%{tde_libdir}/jni/libtdejava.la
%{tde_libdir}/jni/libtdejava.so.*
%doc tdejava/ChangeLog
+
%endif
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
+
%package -n trinity-libtrinity-jni-devel
Summary: Development files for tdelibs bindings for java ( Native libraries ) [Trinity]
Group: Development/Languages/Java
@@ -523,6 +545,7 @@ This package is part of the official TDE bindings module.
%files -n trinity-libtrinity-jni-devel
%defattr(-,root,root,-)
%{tde_libdir}/jni/libtdejava.so
+
%endif
##########
@@ -648,6 +671,8 @@ Perl bindings to the DCOP interprocess communication protocol used by TDE
##########
+%if 0%{with_python}
+
%package -n python-dcop
Summary: DCOP bindings for Python
Group: System/Libraries
@@ -670,6 +695,8 @@ This package is part of the official TDE bindings module.
%{python_sitearch}/pcop.so
%{python_sitearch}/pydcop.py*
+%endif
+
##########
%package -n trinity-libkjsembed1
@@ -760,7 +787,7 @@ This package is part of the official TDE bindings module.
##########
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
%package -n trinity-juic
Summary: The Qt Java UI Compiler
Group: Development/Languages/Java
@@ -1000,14 +1027,14 @@ Provides: trinity-kdebindings-devel = %{?epoch:%{epoch}:}%{version}-%{release}
# Metapackage
Requires: trinity-libsmoketqt-devel = %{?epoch:%{epoch}:}%{version}-%{release}
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
Requires: trinity-libdcop3-java-devel = %{?epoch:%{epoch}:}%{version}-%{release}
%endif
Requires: trinity-libsmoketde-devel = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-libkjsembed-devel = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-libxparts-devel = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-libdcop-c-devel = %{?epoch:%{epoch}:}%{version}-%{release}
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
Requires: trinity-libtqt3-jni-devel = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: trinity-libtrinity-jni-devel = %{?epoch:%{epoch}:}%{version}-%{release}
%endif
@@ -1125,10 +1152,12 @@ EXTRA_INCLUDES="/usr/include/ruby-%{rb_ver}:/usr/include/ruby-%{rb_ver}/%{_targe
\
--with-extra-includes=%{_includedir}/tqscintilla:${EXTRA_INCLUDES} \
--with-extra-libs=%{tde_libdir} \
+%if 0%{with_python}
--with-pythondir=%{_usr} \
+%endif
\
- %{?_with_java} %{!?_with_java:--without-java} \
- %{?_enable_qscintilla} %{!?_enable_qscintilla:--disable-qscintilla}
+ %{?with_java:--with-java=%{java_home}} %{!?with_java:--without-java} \
+ %{?with_qscintilla:--enable-qscintilla} %{!?with_qscintilla:--disable-qscintilla}
# Build dcopperl with specific options
pushd dcopperl
@@ -1154,7 +1183,7 @@ export PATH="%{tde_bindir}:${PATH}"
find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
-o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
-%if "%{?_with_java}" != ""
+%if 0%{?with_java}
# Installs juic
%__install -D -m 755 qtjava/designer/juic/bin/juic %{?buildroot}%{tde_bindir}/juic
%__install -d -m 755 %{?buildroot}%{tde_datadir}/juic/common