summaryrefslogtreecommitdiffstats
path: root/redhat/tdevelop/tdevelop-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/tdevelop/tdevelop-14.0.0.spec')
-rw-r--r--redhat/tdevelop/tdevelop-14.0.0.spec10
1 files changed, 5 insertions, 5 deletions
diff --git a/redhat/tdevelop/tdevelop-14.0.0.spec b/redhat/tdevelop/tdevelop-14.0.0.spec
index 749b11ba2..43a5fd862 100644
--- a/redhat/tdevelop/tdevelop-14.0.0.spec
+++ b/redhat/tdevelop/tdevelop-14.0.0.spec
@@ -577,7 +577,7 @@ export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
# Specific path for RHEL4
if [ -d /usr/X11R6 ]; then
- export CXXFLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
+ export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
# c references
@@ -592,10 +592,10 @@ pushd c_cpp_reference-2.0.2_for_KDE_3.0
--with-extra-libs=%{tde_libdir}
popd
-%if 0%{?rhel} || 0%{?fedora} || 0%{?suse_version}
-%__mkdir_p build
-cd build
-%endif
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
# Warning: GCC visibility causes FTBFS [Bug #1285]
%cmake \