summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kxmleditor/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/kxmleditor/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kxmleditor/debian/rules17
1 files changed, 12 insertions, 5 deletions
diff --git a/ubuntu/_base/applications/kxmleditor/debian/rules b/ubuntu/_base/applications/kxmleditor/debian/rules
index 2aebaac7b..cee2a3058 100755
--- a/ubuntu/_base/applications/kxmleditor/debian/rules
+++ b/ubuntu/_base/applications/kxmleditor/debian/rules
@@ -1,12 +1,19 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"