summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/libcarddav/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/libcarddav/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/libcarddav/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/ubuntu/_base/dependencies/libcarddav/debian/rules b/ubuntu/_base/dependencies/libcarddav/debian/rules
index 56e8f5415..c75240154 100755
--- a/ubuntu/_base/dependencies/libcarddav/debian/rules
+++ b/ubuntu/_base/dependencies/libcarddav/debian/rules
@@ -7,9 +7,16 @@ include debian/cdbs/debian-tde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
-DWITH_ALL_OPTIONS="ON" \
-DBUILD_ALL="ON"