summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqtinterface/debian/rules25
1 files changed, 9 insertions, 16 deletions
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/rules b/ubuntu/_base/dependencies/tqtinterface/debian/rules
index d642db97b..0db17ad7b 100755
--- a/ubuntu/_base/dependencies/tqtinterface/debian/rules
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/rules
@@ -1,28 +1,21 @@
#! /usr/bin/make -f
-# see debian/rules file for tdesvn for cmake examples
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_KDE_APIDOX := yes
+include debian/cdbs/debian-tde.mk
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DBUILD_ALL="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
-# never build in parallel, regardless of DEB_BUILD_OPTIONS.
-DEB_BUILD_PARALLEL = true
-
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR)