summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kchmviewer/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/kchmviewer/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kchmviewer/debian/rules157
1 files changed, 157 insertions, 0 deletions
diff --git a/ubuntu/lucid_automake/applications/kchmviewer/debian/rules b/ubuntu/lucid_automake/applications/kchmviewer/debian/rules
new file mode 100755
index 000000000..4adaf88da
--- /dev/null
+++ b/ubuntu/lucid_automake/applications/kchmviewer/debian/rules
@@ -0,0 +1,157 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
+DEB_CONFIGURE_PREFIX := /opt/kde3
+DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+CFLAGS = -Wall -g
+
+CONFIGURE_OPTIONS_KDE = \
+ --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib \
+ --includedir=/opt/kde3/include/kde --mandir=/opt/kde3/share/man \
+ --with-qt-dir=$(qtdir) \
+ --sysconfdir=$(sysconfdir) \
+ --infodir=/opt/kde3/share/info \
+ --disable-debug --disable-rpath \
+ --with-kde
+
+CONFIGURE_OPTIONS_NOKDE = \
+ --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=/opt/kde3 --with-qt-dir=$(qtdir) \
+ --sysconfdir=$(sysconfdir) \
+ --infodir=/opt/kde3/share/info --mandir=/opt/kde3/share/man \
+ --disable-debug --disable-rpath
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+-include debian/debiandirs
+
+#build: debian/build-kde debian/build-nokde
+build: patch debian/build-kde debian/build-nokde
+
+patch: patch-stamp
+patch-stamp:
+ dpatch apply-all
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+ touch patch-stamp
+
+unpatch:
+ dpatch deapply-all
+ $(RM) -rf patch-stamp debian/patched
+
+debian/build-nokde:
+ dh_testdir
+# automake
+# autoconf
+ test -e config.sub -a -L config.sub || \
+ ln -sf /usr/share/misc/config.sub config.sub
+ test -e config.guess -a -L config.guess || \
+ ln -sf /usr/share/misc/config.guess config.guess
+
+ mkdir build-nokde && cd build-nokde && ../configure CFLAGS="$(CFLAGS)" $(CONFIGURE_OPTIONS_NOKDE)
+ $(MAKE) -C build-nokde
+ touch debian/build-nokde
+
+debian/build-kde:
+ dh_testdir
+# automake
+# autoconf
+ test -e config.sub -a -L config.sub || \
+ ln -sf /usr/share/misc/config.sub config.sub
+ test -e config.guess -a -L config.guess || \
+ ln -sf /usr/share/misc/config.guess config.guess
+
+ mkdir build-kde && cd build-kde && ../configure CFLAGS="$(CFLAGS)" $(CONFIGURE_OPTIONS_KDE)
+ $(MAKE) -C build-kde
+ touch debian/build-kde
+
+clean: unpatch
+ dh_testdir
+ dh_testroot
+ $(RM) -f build-stamp
+ $(RM) -rf debian/kchmviewer{,-nokde}
+ $(RM) -rf build{-kde,-nokde}
+ $(RM) -f debian/build{-kde,-nokde}
+ [ ! -f Makefile ] || $(MAKE) distclean
+ $(RM) config.sub config.guess
+ dh_clean
+
+install: build install-common debian/install-kde debian/install-nokde
+install-common:
+ dh_testdir
+ dh_clean -k
+ dh_installdirs
+
+debian/install-kde:
+ dh_testroot
+ $(MAKE) -C build-kde install DESTDIR=$(CURDIR)/debian/kchmviewer-kde3
+ $(MAKE) -C build-kde/src/pics install DESTDIR=$(CURDIR)/debian/kchmviewer-kde3
+ mkdir -p $(CURDIR)/debian/kchmviewer-kde3/opt/kde3/share/man
+ cp -Rp $(CURDIR)/debian/additions/kchmviewer.1 $(CURDIR)/debian/kchmviewer-kde3/opt/kde3/share/man/kchmviewer.1
+
+debian/install-nokde:
+ dh_testroot
+ $(MAKE) -C build-nokde install DESTDIR=$(CURDIR)/debian/kchmviewer-nokde-kde3 kde_icondir=$(DESTDIR)/opt/kde3/share/icons
+ mkdir -p $(CURDIR)/debian/kchmviewer-nokde-kde3/opt/kde3/share/man
+ mv $(CURDIR)/debian/additions/kchmviewer.1 $(CURDIR)/debian/kchmviewer-nokde-kde3/opt/kde3/share/man/kchmviewer.1
+
+# Build architecture-independent files here.
+binary-indep: build
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_installexamples
+# dh_install
+ dh_installmenu
+# dh_installdebconf
+# dh_installmime
+# dh_installinfo
+# dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install