summaryrefslogtreecommitdiffstats
path: root/ubuntu/lucid_automake/applications/kdmtheme/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/lucid_automake/applications/kdmtheme/debian/rules')
-rwxr-xr-xubuntu/lucid_automake/applications/kdmtheme/debian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/ubuntu/lucid_automake/applications/kdmtheme/debian/rules b/ubuntu/lucid_automake/applications/kdmtheme/debian/rules
new file mode 100755
index 000000000..c6fa4d063
--- /dev/null
+++ b/ubuntu/lucid_automake/applications/kdmtheme/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/kde3/include/kde
+DEB_CONFIGURE_MANDIR := /opt/kde3/share/man
+DEB_CONFIGURE_PREFIX := /opt/kde3
+DEB_CONFIGURE_INFODIR := /opt/kde3/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/kde3 --with-extra-libs=/opt/kde3/lib --with-extra-includes=/opt/kde3/include/kde
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+install/kdmtheme-kde3::
+ install -D -p -m644 debian/kdmtheme.lintian-overrides \
+ debian/kdmtheme-kde3/usr/share/lintian/overrides/kdmtheme-kde3
+
+get-orig-source:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]||mkdir -p ../tarballs
+ @@dpatch-get-origtargz ../tarballs
+