summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/k3b-i18n/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/k3b-i18n/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/k3b-i18n/debian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/k3b-i18n/debian/rules b/ubuntu/maverick/applications/k3b-i18n/debian/rules
index cbe5c9312..108c07633 100755
--- a/ubuntu/maverick/applications/k3b-i18n/debian/rules
+++ b/ubuntu/maverick/applications/k3b-i18n/debian/rules
@@ -28,6 +28,17 @@ endif
config.status: configure
dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
# Add here commands to configure the package.
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=$(DEB_CONFIGURE_PREFIX) \