summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/koffice-i18n/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/koffice-i18n/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/koffice-i18n/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/koffice-i18n/debian/rules b/ubuntu/maverick/applications/koffice-i18n/debian/rules
index 9bb59484f..478c97b9d 100755
--- a/ubuntu/maverick/applications/koffice-i18n/debian/rules
+++ b/ubuntu/maverick/applications/koffice-i18n/debian/rules
@@ -3,6 +3,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
languages = `ls -1d *i18n*`
build-stamp:
@@ -81,7 +84,7 @@ binary-indep: build
dh_installdeb
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep