summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/smb4k/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/smb4k/debian')
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/README.Debian8
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/cdbs/team-members16
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/changelog222
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/compat1
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/control17
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/copyright29
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/docs3
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/menu8
-rwxr-xr-xubuntu/maverick/applications/smb4k/debian/rules29
-rw-r--r--ubuntu/maverick/applications/smb4k/debian/watch6
15 files changed, 679 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/smb4k/debian/README.Debian b/ubuntu/maverick/applications/smb4k/debian/README.Debian
new file mode 100644
index 000000000..995d110e5
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/README.Debian
@@ -0,0 +1,8 @@
+smb4k for Debian
+----------------
+
+Thanks to Mindaugas Zaksauskas and Alexander Reinholdt who packaged a first version of this program.
+I modified for an up-to-date policy and added cdbs debianizing tool support.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 18 Jun 2004 17:00:05 +0200
+
diff --git a/ubuntu/maverick/applications/smb4k/debian/cdbs/buildvars.mk b/ubuntu/maverick/applications/smb4k/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/ubuntu/maverick/applications/smb4k/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/smb4k/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..47e83ef4a
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/maverick/applications/smb4k/debian/cdbs/kde.mk b/ubuntu/maverick/applications/smb4k/debian/cdbs/kde.mk
new file mode 100644
index 000000000..5b6508f8c
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/kde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/maverick/applications/smb4k/debian/cdbs/team-members b/ubuntu/maverick/applications/smb4k/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/maverick/applications/smb4k/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/smb4k/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/ubuntu/maverick/applications/smb4k/debian/cdbs/versions.pl b/ubuntu/maverick/applications/smb4k/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/smb4k/debian/changelog b/ubuntu/maverick/applications/smb4k/debian/changelog
new file mode 100644
index 000000000..aa42ce16c
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/changelog
@@ -0,0 +1,222 @@
+smb4k-trinity (0.9.4-0ubuntu3) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
+
+smb4k-trinity (0.9.4-0ubuntu2) intrepid; urgency=low
+
+ * Moved KDE3 to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 05 March 2009 01:11:00 -0600
+
+smb4k-trinity (0.9.4-0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 07 Feb 2009 21:34:00 -0600
+
+smb4k (0.9.4-1) unstable; urgency=low
+
+ * New upstream release.
+ (closes: #477419)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 29 Apr 2008 11:00:22 +0200
+
+smb4k (0.9.2-1) unstable; urgency=low
+
+ * New upstream release
+ * Updated minimal build-deps to 3.3 as required upstream.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 28 Jan 2008 10:48:11 +0100
+
+smb4k (0.9.1-1) unstable; urgency=low
+
+ * New upstream release.
+ (closes: #343950, #456077, #461370)
+ * Policy bumped to 3.7.3 (no changes)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 18 Jan 2008 14:48:20 +0100
+
+smb4k (0.8.6-1) unstable; urgency=low
+
+ * New upstream release.
+ * Introduced Homepage field in debian/control
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 22 Oct 2007 20:06:08 +0200
+
+smb4k (0.8.4-2) unstable; urgency=low
+
+ * debian/menu transitioned to new sections.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 17 Jul 2007 23:03:05 +0200
+
+smb4k (0.8.4-1) unstable; urgency=low
+
+ * New upstream release with minor fixes.
+ * debian/copyright file updated.
+ (closes: #432224)
+ * debian/watch revised.
+ * debian/control revised for description.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 10 Jul 2007 09:56:17 +0200
+
+smb4k (0.8.3-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 18 Jun 2007 21:38:37 +0200
+
+smb4k (0.8.1-1) unstable; urgency=high
+
+ * New upstream release (fixes a few security issues)
+ (closes: #417697)
+ * Revised watch file.
+
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 10 Apr 2007 11:40:40 +0200
+
+smb4k (0.8.0-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 22 Dec 2006 12:27:05 +0100
+
+smb4k (0.7.5-1) unstable; urgency=high
+
+ * New upstream release
+ This version fixes a grave security bug present in all 0.7 versions with
+ sudoers file management.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 27 Nov 2006 12:57:57 +0100
+
+smb4k (0.7.3-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Wed, 25 Oct 2006 23:30:11 +0200
+
+smb4k (0.7.2-1) unstable; urgency=low
+
+ * New upstream version.
+ * Moved debian/watch to version 3 syntax.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Thu, 3 Aug 2006 14:55:25 +0200
+
+smb4k (0.7.1-1) unstable; urgency=low
+
+ * New upstream release
+ This version works only with Samba 3.0+
+ * Policy bumped to 3.7.2 without changes.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Sun, 25 Jun 2006 10:55:40 +0200
+
+smb4k (0.6.9-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 24 Mar 2006 17:01:31 +0100
+
+smb4k (0.6.8-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 17 Mar 2006 22:55:33 +0100
+
+smb4k (0.6.7-1) unstable; urgency=low
+
+ * New upstream release
+ * Removed superfluous libfam-dev build-dep.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Sun, 5 Feb 2006 23:19:33 +0100
+
+smb4k (0.6.5-1) unstable; urgency=low
+
+ * New upstream release
+ (closes: #343094,#314240)
+ * Transitioned to xorg dependencies.
+ (closes: #346905)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 9 Jan 2006 15:25:45 +0100
+
+smb4k (0.6.4-1) unstable; urgency=high
+
+ * New upstream release
+ * Truly fix of #313908 and related issues.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 4 Nov 2005 14:54:26 +0100
+
+smb4k (0.6.3-1) unstable; urgency=high
+
+ * New upstream release
+ Fixes a few security flaws due to symlinking abuse.
+ IMHO it require major changes to properly manage IPC with sudo/super,
+ anywy better than nothing...
+ * Little modification (partially yet done by upstream) to de.po
+ (closes: #313908)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Wed, 31 Aug 2005 15:26:55 +0200
+
+smb4k (0.6.1-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 23 Aug 2005 23:44:01 +0200
+
+smb4k (0.6.0-1) unstable; urgency=low
+
+ * New upstream release
+ * Added missing kdebase-dev build-dep
+ * Policy bumped to 3.6.2
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 23 Aug 2005 23:29:26 +0200
+
+smb4k (0.5.2-1) unstable; urgency=low
+
+ * New upstream release
+ (closes: #294458, #296458)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Tue, 29 Mar 2005 12:15:53 +0200
+
+smb4k (0.5.1-1) unstable; urgency=low
+
+ * New upstream release
+ * Added sudo to recommended pkgs in control file.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 31 Jan 2005 10:35:10 +0100
+
+smb4k (0.5.0-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Thu, 13 Jan 2005 15:21:07 +0100
+
+smb4k (0.4.1a-1) unstable; urgency=high
+
+ * New upstream release.
+ A severe bug in Smb4K's exit code has been found and fixed, which led
+ under certain circumstances to complete data loss on remote shares.
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 6 Sep 2004 11:40:26 +0200
+
+smb4k (0.4.1-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Mon, 30 Aug 2004 21:10:00 +0200
+
+smb4k (0.4.0-2) unstable; urgency=low
+
+ * Missing debhelper dependency added. It is only recommended in cdbs, why?
+ (closes: #257367)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Sat, 3 Jul 2004 10:14:59 +0200
+
+smb4k (0.4.0-1) unstable; urgency=low
+
+ * Initial release.
+ (closes: #255072)
+
+ -- Francesco Paolo Lovergine <frankie@debian.org> Fri, 18 Jun 2004 20:02:30 +0200
+
diff --git a/ubuntu/maverick/applications/smb4k/debian/compat b/ubuntu/maverick/applications/smb4k/debian/compat
new file mode 100644
index 000000000..b8626c4cf
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/ubuntu/maverick/applications/smb4k/debian/control b/ubuntu/maverick/applications/smb4k/debian/control
new file mode 100644
index 000000000..c4fb618b7
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/control
@@ -0,0 +1,17 @@
+Source: smb4k-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: kdebase-trinity-dev, kdelibs4-trinity-dev, libart-2.0-dev, libpng3-dev, zlib1g-dev, debhelper (>= 4.1.0), cdbs, libx11-dev, libxext-dev, libxpm-dev, x-dev | x11proto-core-dev | libx11-dev, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+Homepage: http://smb4k.berlios.de/
+
+Package: smb4k-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, samba-common, smbclient, smbfs
+Recommends: super | sudo-trinity
+Description: A Samba (SMB) share advanced browser for KDE3
+ Smb4K is a SMB (Windows) share browser for KDE. It uses the Samba software
+ suite to access the SMB shares of the local network neighborhood. Its purpose
+ is to provide a program that's easy to use and has as many features as
+ possible.
diff --git a/ubuntu/maverick/applications/smb4k/debian/copyright b/ubuntu/maverick/applications/smb4k/debian/copyright
new file mode 100644
index 000000000..d32c049ef
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/copyright
@@ -0,0 +1,29 @@
+This package was debianized by Alexander Reinholdt <dustpuppy@mail.berlios.de>
+on Sun, 2 May 2004 19:16:57 +0200.
+Keep up to date by Francesco Paolo Lovergine <frankie@debian.org>
+
+It was downloaded from http://smb4k.berlios.de/download.html
+
+Upstream Authors: Alexander Reinholdt <dustpuppy@users.berlios.de>
+ Massimo Callegari <massimocallegari@yahoo.it>
+ Franck Babin <babinfranck@yahoo.ca>
+
+Copyright:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ 02111-1307, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
diff --git a/ubuntu/maverick/applications/smb4k/debian/docs b/ubuntu/maverick/applications/smb4k/debian/docs
new file mode 100644
index 000000000..e4acf0127
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/docs
@@ -0,0 +1,3 @@
+README
+AUTHORS
+BUGS
diff --git a/ubuntu/maverick/applications/smb4k/debian/menu b/ubuntu/maverick/applications/smb4k/debian/menu
new file mode 100644
index 000000000..7f7c9cb2a
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/menu
@@ -0,0 +1,8 @@
+?package(smb4k):\
+ needs="X11"\
+ section="Applications/Network"\
+ hints="KDE"\
+ kderemove="1"\
+ title="SAMBA for KDE"\
+ longtitle="SAMBA Advanced Browser"\
+ command="/opt/trinity/bin/smb4k"
diff --git a/ubuntu/maverick/applications/smb4k/debian/rules b/ubuntu/maverick/applications/smb4k/debian/rules
new file mode 100755
index 000000000..a7f5808ef
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+#
+# Uhm, too much complicated eh?
+#
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
diff --git a/ubuntu/maverick/applications/smb4k/debian/watch b/ubuntu/maverick/applications/smb4k/debian/watch
new file mode 100644
index 000000000..70154d877
--- /dev/null
+++ b/ubuntu/maverick/applications/smb4k/debian/watch
@@ -0,0 +1,6 @@
+version=3
+opts=downloadurlmangle=s/prdownload/download/ \
+ http://developer.berlios.de/project/showfiles.php?group_id=769 \
+ http://prdownload.berlios.de/smb4k/smb4k-([\d\.]+)\.tar\.bz2
+
+