summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/libraries/libksquirrel/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/libraries/libksquirrel/debian/rules')
-rwxr-xr-xubuntu/maverick/libraries/libksquirrel/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/libraries/libksquirrel/debian/rules b/ubuntu/maverick/libraries/libksquirrel/debian/rules
index 4d113ccd7..f5bc572dc 100755
--- a/ubuntu/maverick/libraries/libksquirrel/debian/rules
+++ b/ubuntu/maverick/libraries/libksquirrel/debian/rules
@@ -16,6 +16,9 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -88,7 +91,7 @@ binary-arch: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install