summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/tde-i18n/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/tde-i18n/debian/rules')
-rwxr-xr-xubuntu/maverick/tde-i18n/debian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/ubuntu/maverick/tde-i18n/debian/rules b/ubuntu/maverick/tde-i18n/debian/rules
index fcbacb90a..c5ae84be2 100755
--- a/ubuntu/maverick/tde-i18n/debian/rules
+++ b/ubuntu/maverick/tde-i18n/debian/rules
@@ -22,6 +22,11 @@ DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ DEB_PARALLEL_JOBS ?= $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+DEB_MAKE_PARALLEL ?= $(and $(DEB_BUILD_PARALLEL),$(DEB_PARALLEL_JOBS),-j$(DEB_PARALLEL_JOBS))
+
configkde=\
--disable-rpath \
--prefix=$(DEB_CONFIGURE_PREFIX) \
@@ -57,13 +62,13 @@ $(STAMP_BUILD):
$(MAKE) -f ../admin/Makefile.common && \
cd build && \
../configure --build=build $(configkde) && \
- $(MAKE); \
+ $(MAKE) $(DEB_MAKE_PARALLEL); \
fi
if [ -e $(cur_lang_dir)/CMakeLists.txt ]; then \
([ -e $(cur_lang_dir)/cmake ] || ln -s ../cmake $(cur_lang_dir)) && \
cd $(cur_lang_dir)/build && \
cmake .. $(DEB_CMAKE_EXTRA_FLAGS) && \
- $(MAKE); \
+ $(MAKE) $(DEB_MAKE_PARALLEL); \
fi
touch $@
@@ -87,7 +92,7 @@ install:: $(I18N_INSTALL)
cp -aR debian/$(I18N_DEST_PREFIX)-zh_TW-trinity/* debian/$(I18N_DEST_PREFIX)-zhtw-trinity/
$(I18N_INSTALL):
- cd $(cur_lang_dir)/build && $(MAKE) install DESTDIR=$(CURDIR)/debian/$(cur_pkg)-trinity
+ cd $(cur_lang_dir)/build && $(MAKE) install DESTDIR=$(CURDIR)/debian/$(cur_pkg)-trinity $(DEB_MAKE_PARALLEL)
clean: $(I18N_CLEAN) debian-clean