summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/filelight/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/filelight/debian')
-rw-r--r--ubuntu/precise/applications/filelight/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/precise/applications/filelight/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--ubuntu/precise/applications/filelight/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/precise/applications/filelight/debian/cdbs/team-members16
-rw-r--r--ubuntu/precise/applications/filelight/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/precise/applications/filelight/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/precise/applications/filelight/debian/changelog197
-rw-r--r--ubuntu/precise/applications/filelight/debian/control22
-rw-r--r--ubuntu/precise/applications/filelight/debian/copyright42
-rw-r--r--ubuntu/precise/applications/filelight/debian/filelight.163
-rw-r--r--ubuntu/precise/applications/filelight/debian/menu6
-rw-r--r--ubuntu/precise/applications/filelight/debian/patches/series0
-rwxr-xr-xubuntu/precise/applications/filelight/debian/rules42
-rw-r--r--ubuntu/precise/applications/filelight/debian/source/format1
-rw-r--r--ubuntu/precise/applications/filelight/debian/source/options6
15 files changed, 735 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/filelight/debian/cdbs/buildvars.mk b/ubuntu/precise/applications/filelight/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/ubuntu/precise/applications/filelight/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/applications/filelight/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..311dc059d
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/precise/applications/filelight/debian/cdbs/kde.mk b/ubuntu/precise/applications/filelight/debian/cdbs/kde.mk
new file mode 100644
index 000000000..765560c89
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/precise/applications/filelight/debian/cdbs/team-members b/ubuntu/precise/applications/filelight/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/precise/applications/filelight/debian/cdbs/uploaders.mk b/ubuntu/precise/applications/filelight/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/ubuntu/precise/applications/filelight/debian/cdbs/versions.pl b/ubuntu/precise/applications/filelight/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/precise/applications/filelight/debian/changelog b/ubuntu/precise/applications/filelight/debian/changelog
new file mode 100644
index 000000000..57ef19426
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/changelog
@@ -0,0 +1,197 @@
+filelight-trinity (1.0-2ubuntu5) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
+
+filelight-trinity (1.0-2ubuntu4) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 March 2009 01:11:00 -0600
+
+filelight-trinity (1.0-2ubuntu3) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Mon, 09 Feb 2009 10:27:00 -0600
+
+filelight (1.0-2ubuntu2) intrepid; urgency=low
+
+ * Remove documentation, it conflicts with the -l10n package (LP: #245974)
+
+ -- Harald Sitter <apachelogger@ubuntu.com> Sun, 24 Aug 2008 00:56:23 +0200
+
+filelight (1.0-2ubuntu1) intrepid; urgency=low
+
+ * Merge from debian unstable, remaining changes:
+ - Changed Maintainer field per spec
+ - debian/rules: prevent the installation of locale files (they are provided
+ by the filelight-l10n package)
+ - debian/patches
+ + Don't merge patches which change any Makefile.in, they
+ would break.
+
+ -- Harald Sitter <apachelogger@ubuntu.com> Wed, 07 May 2008 10:00:29 +0100
+
+filelight (1.0-2) unstable; urgency=low
+
+ * 'man filelight' typos: "representating", "filesystem" and
+ "diskspace" (Closes: #452618). Thanks to A. Costa.
+ * Update policy to 3.7.3. No changes needed.
+ * Fixed Vcs-Svn and VCs-Browser fields.
+ * Reordered CDBS build rules and removing autotools.mk since it clashes with
+ kde.mk.
+ * Moving to quilt patch system.
+ * Removed dpatch comments from 10_fix-filelight.desktop
+ * Reworked buildsystem: added patches 98_buildprep; removed
+ 01_configure-update, 02_dist-files and 07_install-radial-map.diff; updated
+ 05_fPIX_radialmap_part.
+ * Removed watch file.
+
+ -- Raúl Sánchez Siles <rasasi78@gmail.com> Tue, 06 May 2008 17:10:35 +0200
+
+filelight (1.0-1) unstable; urgency=low
+
+ * New upstream release: Crashes fix, displaying non-latin1 correctly and
+ several new features. (Closes: #445935, #424741)
+ * Splitted l10n to a new package.
+ * Bugs closed:
+ + filelight always places hover information on first monitor (Closes:
+ #255896)
+ + filelight doesn't handle utf-8 files (Closes: #256423)
+ + always crashing on exit (Closes: #404460)
+ + bug in filelight - crash on exit (Closes: #356626)
+ + glibc detects free() of invalid pointer on exit (Closes: #343903)
+ + memory usage is obscene (Closes: #231399)
+ + lots of noise on stderr from RadialMap methods (Closes: #343905)
+ + very large files and directories lead to confusion (Closes: #393827)
+ + Filelight ignores large files (Closes: #341680)
+ + Piles of WARNING messages on startup, but it works. (Closes:
+ #307717)
+ + filelight lacks a manpage [patch] (Closes: #414934). Thanks to
+ James R. Van Zandt.
+ + Spelling mistake in package description (Closes: #363410). Thanks to
+ James Westby.
+ + please build with --disable-debug to prevent spurious stdout-output
+ (Closes: #408554)
+ + filelight(GNU/k*BSD): FTBFS: out of date config.sub/config.guess
+ (Closes: #304605)
+ + lots of noise on stderr from RadialMap methods (Closes: #343905)
+ * Packaging issues:
+ + Changed packaging to CDBS.
+ + Provide upstream AUTHORS file.
+ + Honour the nostrip in the DEB_BUILD_OPTIONS. (Closes: #436852)
+ + Changed menu section to Applications/File Management to comply with newer
+ menu policy.
+ + Implemented dpatch, avoiding direct upstream patching(ugly).
+ + please remove old editor backup files from diff (Closes: #354706)
+ + Update package policy to latest 3.7.2.
+ + Change Uploader(me) and Maintainers(Debian KDE Extras Team).
+
+ -- Raúl Sánchez Siles <rasasi78@gmail.com> Fri, 16 Nov 2007 19:20:42 +0100
+
+filelight (1.0-0ubuntu2) gutsy; urgency=low
+
+ * Removed postrm and postinst since they are not needed
+ * Added patch for desktop file typo
+
+ -- Harald Sitter <sitter.harald@gmail.com> Mon, 4 Jun 2007 21:58:53 +0200
+
+filelight (1.0-0ubuntu1) gutsy; urgency=low
+
+ * New Upstream Release
+ * Standards-Version: 3.7.2
+ * Added manpage
+ * Moved to cdbs
+ * Removed debian/conffiles due to cdbs
+
+ -- Harald Sitter <sitter.harald@gmail.com> Sun, 22 Apr 2007 14:48:10 +0200
+
+filelight (0.99beta6-1ubuntu1) dapper; urgency=low
+
+ * Resynchronise with Debian.
+
+ -- Benjamin Montgomery <bmontgom@montynet.org> Tue, 6 Dec 2005 22:12:09 -0600
+
+filelight (0.99beta6-1) unstable; urgency=low
+
+ * New upstream (beta) release. Closes: #304497
+ * Can delete files with spaces in the filename. Closes: #265384
+
+ * Rebuilt for C++ transition. Closes: #327002, #327231
+
+ * debian/rules (checkdir): update for source reorganization.
+ * debian/rules (binary-arch): deal with the new libfilelight.so.
+
+ * debian/menu: quote all strings (via lintian).
+ * debian/rules (binary-arch): install menu file to /usr/share/menu
+ rather than /usr/lib/menu (via lintian).
+
+ * debian/control (Standards-Version): updated to 3.6.2.1.
+ * debian/copyright: update download location to be non-version specific.
+ Update FSF address (via lintian).
+
+ * debian/control (Build-Depends): add autoconf and gettext.
+
+ * src/part/radial/Makefile.am: add -fPIC to CFLAGS.
+ * src/part/radial/Makefile.in: add -fPIC to INCLUDES. Copied from
+ Michael Vogt's Ubuntu change. Not a good/proper long term solution,
+ but it'll compile at least.
+
+ * debian/rules (clean): also remove po/*.gmo, autom4te.cache and
+ config.log to keep diff.gz clean.
+
+ -- James Troup <james@nocrew.org> Mon, 19 Sep 2005 01:43:42 +0100
+
+filelight (0.99beta6-0ubuntu3) breezy; urgency=low
+
+ * rebuild for c++ transition
+ * fixed a missing -fPIC in src/part/radialMap
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 14 Sep 2005 15:05:38 +0200
+
+filelight (0.99beta6-0ubuntu2) breezy; urgency=low
+
+ * Add autoconf as build-dep
+
+ -- Jonathan Riddell <jr@jriddell.org> Tue, 7 Jun 2005 17:05:56 +0000
+
+filelight (0.99beta6-0ubuntu1) breezy; urgency=low
+
+ * New upstream release
+
+ -- Jonathan Riddell <jr@jriddell.org> Tue, 7 Jun 2005 14:30:49 +0000
+
+filelight (0.6.4.1-1build1) breezy; urgency=low
+
+ * Rebuild for new C++ ABI
+
+ -- Matthias Klose <doko@ubuntu.com> Mon, 6 Jun 2005 16:34:50 +0000
+
+filelight (0.6.4.1-1) unstable; urgency=low
+
+ * New upstream release.
+
+ * debian/menu: new file, provided by Justin B Rye <jbr@edlug.org.uk>.
+ Closes: #234301
+ * debian/postinst: call update-menus.
+ * debian/postrm: likewise.
+ * debian/rules: install menu file and postinst and postrm.
+
+ * src/filelight.desktop: Patch from Christoffer Sawicki <qerub@home.se>
+ to fix typo (Generic Name -> GenericName). Closes: #230670
+
+ * debian/control: reword extended description to include 'disk usage' to
+ aid in searching with apt-cache as suggested by Remi Vanicat
+ <vanicat@debian.org>. Closes: #231060
+
+ -- James Troup <james@nocrew.org> Mon, 23 Feb 2004 14:55:16 +0000
+
+filelight (0.6.3.1-1) unstable; urgency=low
+
+ * Initial Release. Closes: #228812
+
+ -- James Troup <james@nocrew.org> Wed, 21 Jan 2004 03:11:00 +0100
+
diff --git a/ubuntu/precise/applications/filelight/debian/control b/ubuntu/precise/applications/filelight/debian/control
new file mode 100644
index 000000000..a85cf37fe
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/control
@@ -0,0 +1,22 @@
+Source: filelight-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
+Uploaders: Ral Snchez Siles <rasasi78@gmail.com>
+Standards-Version: 3.8.4
+Build-Depends: debhelper (>= 5.0), cdbs, tdelibs4-trinity-dev, xutils, chrpath, gettext, quilt (>= 0.40), automake, autoconf, libtool, libltdl-dev
+Homepage: http://www.methylblue.com/filelight/
+
+Package: filelight-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: filelight-trinity (<< 4:14.0.0)
+Breaks: filelight-trinity (<< 4:14.0.0)
+Description: show where your diskspace is being used [Trinity]
+ Filelight allows you to understand your disk usage by graphically
+ representing your filesystem as a set of concentric, segmented rings.
+ .
+ It is like a pie-chart, but the segments nest, allowing you to see both
+ which directories take up all your space, and which directories
+ and files inside those directories are the real culprits.
diff --git a/ubuntu/precise/applications/filelight/debian/copyright b/ubuntu/precise/applications/filelight/debian/copyright
new file mode 100644
index 000000000..c02dc5949
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/copyright
@@ -0,0 +1,42 @@
+This is Debian GNU's prepackaged version of filelight, a program to
+show you where your diskspace is being used. Debianized by James
+Troup <james@nocrew.org> on Wed, 21 Jan 2004 and reworked by Raúl
+Sánchez Siles <rasasi78@gmail.com> on Fri, 16 Nov 2007 13:03:04 +0100
+
+The Debian packaging is (C) 2007, Raul Sánchez Siles <rasasi78@gmail.com>
+and is licensed under the GPLv2, which can be found at
+'/usr/share/common-licenses/GPL-2'.
+
+It was downloaded from:
+
+ http://www.methylblue.com/filelight/#packages
+
+Upstream Author: Max Howell <max.howell@methylblue.com>
+
+License:
+
+ This package and debian/filelight.1 is free software; you can redistribute
+ it and/or modify it under the terms of the GNU General Public License as
+ published by the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License version 2 can be found at `/usr/share/common-licenses/GPL-2'.
+
+Copyright
+
+Filelight:
+
+ (C) 2005-2006 Max Howell <max.howell@methylblue.com>
+
+debian/filelight.1:
+
+ Copyright (C) 2006 by J. R. Van Zandt <jrvz@comcast.net>
diff --git a/ubuntu/precise/applications/filelight/debian/filelight.1 b/ubuntu/precise/applications/filelight/debian/filelight.1
new file mode 100644
index 000000000..ce932984b
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/filelight.1
@@ -0,0 +1,63 @@
+.\" Hey, EMACS: -*- nroff -*-
+.TH FILELIGHT 1 "March 14, 2007"
+.\" Please adjust this date whenever revising the manpage.
+.SH NAME
+filelight \- graphically display disk usage
+.SH SYNOPSIS
+.B filelight
+.RI [ " path " ]
+.SH DESCRIPTION
+\fBfilelight\fP allows you to understand exactly where your disk space
+is being used by graphically representing your file system as a set
+of concentric segmented rings, where each segment subtends an angle
+proportional to the disk space occupied by that file or directory.
+.PP
+You can specify a directory to scan on startup at the command line eg:
+.nf
+ filelight /home/mxcl
+.fi
+Starting at the root requires a scan of the entire directory tree,
+which may take a while.
+.PP
+\fBfilelight\fP is available in Konqueror under \fBView | View Mode | RadialMap View\fP.
+.SH RUN-TIME COMMANDS
+
+.TP
+.B Hover over segments
+to find out more about the region of the file system it represents.
+.TP
+.B Click on directories
+to see them in more detail (recenter the
+display on that directory).
+.TP
+.B Click on files
+to launch in the appropriate viewer (as configured in
+Konqueror).
+.TP
+.B Middle click
+to open files/directories with Konqueror.
+.TP
+.B Right click on the center white circle
+to manipulate the directory the view is centered about.
+.TP
+.B Enlarge the window
+for more detail - small files are hidden at
+smaller window sizes.
+.SH SEE ALSO
+.BR du (1),
+.BR df (1),
+.BR fsviewer (1),
+.BR gdmap (1),
+.BR philesight (1),
+.BR xcruiser (1).
+.BR xdiskusage (1).
+.br
+.SH BUGS
+Please report any bugs using the built-in bug reporter under
+the "help" menu, or to either filelight@methylblue.com or the forums at
+http://www.methylblue.com/filelight/.
+.SH AUTHOR
+\fBfilelight\fP was written by Max Howell (max.howell@methylblue.com).
+.PP
+This manual page was written by J. R. Van Zandt,
+for the Debian project (but may be used by others).
diff --git a/ubuntu/precise/applications/filelight/debian/menu b/ubuntu/precise/applications/filelight/debian/menu
new file mode 100644
index 000000000..4db4c3f62
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/menu
@@ -0,0 +1,6 @@
+?package(filelight):needs="X11" \
+ section="Apps/System" \
+ hints="KDE, Monitoring, Files" \
+ command="/opt/trinity/bin/filelight" \
+ title="Filelight" \
+ longtitle="Filelight: disk usage as concentric rings"
diff --git a/ubuntu/precise/applications/filelight/debian/patches/series b/ubuntu/precise/applications/filelight/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/patches/series
diff --git a/ubuntu/precise/applications/filelight/debian/rules b/ubuntu/precise/applications/filelight/debian/rules
new file mode 100755
index 000000000..247e26b9d
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+# debian/rules file - for filelight (1.0)
+# Copyright 2007 Raúl Sánchez Siles
+# This packaging is licensed under GPLv2
+# see /usr/share/common-licenses/GPL-2 for details.
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_filelight := debian/filelight.1
+DEB_DH_ALWAYS_EXCLUDE=.svn
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --disable-debug
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+#get-orig-source-dpatch:
+# @@dh_testdir
+# @@[ -d ../tarballs/. ]
+# @@dpatch-get-origtargz ../tarballs
+
+common-install-arch::
+ rm -rf debian/filelight/usr/share/locale/
+ rm -rf debian/filelight/usr/share/doc/tde/
diff --git a/ubuntu/precise/applications/filelight/debian/source/format b/ubuntu/precise/applications/filelight/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/precise/applications/filelight/debian/source/options b/ubuntu/precise/applications/filelight/debian/source/options
new file mode 100644
index 000000000..9d7c8e036
--- /dev/null
+++ b/ubuntu/precise/applications/filelight/debian/source/options
@@ -0,0 +1,6 @@
+# Use bzip2 instead of gzip
+compression = "bzip2"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*