summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/knetstats/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/knetstats/debian')
-rw-r--r--ubuntu/precise/applications/knetstats/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/precise/applications/knetstats/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--ubuntu/precise/applications/knetstats/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/precise/applications/knetstats/debian/cdbs/team-members16
-rw-r--r--ubuntu/precise/applications/knetstats/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/precise/applications/knetstats/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/precise/applications/knetstats/debian/changelog34
-rw-r--r--ubuntu/precise/applications/knetstats/debian/compat1
-rw-r--r--ubuntu/precise/applications/knetstats/debian/control16
-rw-r--r--ubuntu/precise/applications/knetstats/debian/copyright30
-rw-r--r--ubuntu/precise/applications/knetstats/debian/knetstats.1.docbook113
-rw-r--r--ubuntu/precise/applications/knetstats/debian/patches/.gitignore0
-rwxr-xr-xubuntu/precise/applications/knetstats/debian/rules32
-rw-r--r--ubuntu/precise/applications/knetstats/debian/source/format1
-rw-r--r--ubuntu/precise/applications/knetstats/debian/source/options6
-rw-r--r--ubuntu/precise/applications/knetstats/debian/watch3
16 files changed, 592 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/knetstats/debian/cdbs/buildvars.mk b/ubuntu/precise/applications/knetstats/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/ubuntu/precise/applications/knetstats/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/applications/knetstats/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..311dc059d
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/precise/applications/knetstats/debian/cdbs/kde.mk b/ubuntu/precise/applications/knetstats/debian/cdbs/kde.mk
new file mode 100644
index 000000000..765560c89
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/precise/applications/knetstats/debian/cdbs/team-members b/ubuntu/precise/applications/knetstats/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/precise/applications/knetstats/debian/cdbs/uploaders.mk b/ubuntu/precise/applications/knetstats/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/ubuntu/precise/applications/knetstats/debian/cdbs/versions.pl b/ubuntu/precise/applications/knetstats/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/precise/applications/knetstats/debian/changelog b/ubuntu/precise/applications/knetstats/debian/changelog
new file mode 100644
index 000000000..d1015cb26
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/changelog
@@ -0,0 +1,34 @@
+knetstats-trinity (1.6.1-0ubuntu4) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 Nov 2009 11:09:00 -0600
+
+knetstats (1.6.1-0ubuntu2) intrepid; urgency=low
+
+ * Remove kicker dependency
+
+ -- Harald Sitter <apachelogger@ubuntu.com> Sat, 06 Sep 2008 01:37:17 +0200
+
+knetstats (1.6.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+ * debian/patches/kubuntu_02_clean_desktop_file.patch:
+ - Update to apply again.
+ - Comply with current fd.o standard.
+ * debian/patches/kubuntu_03_autoconf.patch: Drop. Now included upstream.
+ * debian/watch: Add.
+
+ -- William Grant <william.grant@ubuntu.org.au> Sat, 10 Nov 2007 12:55:46 +1100
+
+knetstats (1.6-0ubuntu1) edgy; urgency=low
+
+ * Initial Release.
+ * Added kubuntu_01_kdepot.patch for pot files extraction
+ to Rosetta
+ * Added kubuntu_02_clean_desktop_file.patch for good GenericNames
+ in desktop file
+ * Added kubuntu_03_autoconf for autoconf/autoheader 2.6
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sun, 27 Sep 2006 14:14:54 +0200
+
diff --git a/ubuntu/precise/applications/knetstats/debian/compat b/ubuntu/precise/applications/knetstats/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/ubuntu/precise/applications/knetstats/debian/control b/ubuntu/precise/applications/knetstats/debian/control
new file mode 100644
index 000000000..5aa11bdca
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/control
@@ -0,0 +1,16 @@
+Source: knetstats-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 5.0), cdbs, tdelibs4-trinity-dev, docbook2x, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+Homepage: http://knetstats.sourceforge.net/
+
+Package: knetstats-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: knetstats-trinity (<< 4:14.0.0)
+Breaks: knetstats-trinity (<< 4:14.0.0)
+Description: network interfaces monitor for the Trinity systray
+ A simple KDE network monitor that show rx/tx LEDs of any
+ network interface on a system tray icon
diff --git a/ubuntu/precise/applications/knetstats/debian/copyright b/ubuntu/precise/applications/knetstats/debian/copyright
new file mode 100644
index 000000000..bf7dbe0ed
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/copyright
@@ -0,0 +1,30 @@
+This package was debianized by Anthony Mercatante <tonio@ubuntu.com>
+on Wed, 27 Sep 2006 14:17:36 +0200
+
+It was downloaded from http://knetstats.sourceforge.net/
+
+Upstream author is
+ Hugo Parente Lima <hugo_pl@users.sourceforge.net>
+
+Copyright:
+
+ Copyright (C) 2004-2005-2006 by Hugo Parente Lima <hugo_pl@users.sourceforge.net>
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin St - Fifth Floor, Boston, MA 02110-1301 USA
+
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in the /usr/share/common-licenses/GPL file.
diff --git a/ubuntu/precise/applications/knetstats/debian/knetstats.1.docbook b/ubuntu/precise/applications/knetstats/debian/knetstats.1.docbook
new file mode 100644
index 000000000..28b721f53
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/knetstats.1.docbook
@@ -0,0 +1,113 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+]>
+<refentry>
+ <refentryinfo>
+ <author>
+ <firstname>Mercatante</firstname>
+ <surname>Anthony</surname>
+ <email>tonio@ubuntu.com</email>
+ </author>
+ <copyright>
+ <year>2006</year>
+ <holder>Anthony Mercatante</holder>
+ </copyright>
+ <!-- XXX IMPORTANT XXX -->
+ <!-- Keep this date up to date: -->
+ <date>2006-09-27</date>
+ <!-- ^^^^^^^^^^ -->
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>knetstats</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+ <refnamediv>
+ <refname>knetstats</refname>
+ <refpurpose>network interfaces monitor for KDE's systray</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>knetstats</command>
+ <arg choice="opt">
+ <option><replaceable>Qt-options</replaceable></option>
+ </arg>
+ <arg choice="opt">
+ <option><replaceable>KDE-options</replaceable></option>
+ </arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+ <para>
+ network interfaces monitor for KDE's systray.
+ </para>
+ <para>
+ Knetstats is a simple KDE network monitor that show rx/tx LEDs of any network interface on a system tray icon
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+ <para>
+ All <productname>KDE</productname> and <productname>Qt</productname>
+ programs accept a some common command-line options. Password Manager has no
+ application-specific options.
+ </para>
+ <para>
+ <variablelist>
+ <title>Generic options:</title>
+ <varlistentry>
+ <term> <option>--help</option> </term>
+ <listitem> <para>Show help about options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-qt</option> </term>
+ <listitem> <para>Show Qt specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-kde</option> </term>
+ <listitem> <para>Show KDE specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-all</option> </term>
+ <listitem> <para>Show all options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--author</option> </term>
+ <listitem> <para>Show author information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-v</option>, <option>--version</option> </term>
+ <listitem> <para>Show version information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--license</option> </term>
+ <listitem> <para>Show license information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--</option> </term>
+ <listitem> <para>Indicates end of options</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <!-- TODO * add all the rest of the options, but maybe find an automated
+ way to keep it up to date -->
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>COPYRIGHT</title>
+ <para>
+ This manual page was written by Anthony Mercatante
+ <email>tonio@ubuntu.com</email> for the
+ <productname>Debian</productname> system (but may be used by others).
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the <acronym>GNU</acronym> General Public License,
+ Version 2 or any later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in
+ <filename>/usr/share/common-licenses/GPL</filename>.
+ </para>
+ </refsect1>
+</refentry>
+
diff --git a/ubuntu/precise/applications/knetstats/debian/patches/.gitignore b/ubuntu/precise/applications/knetstats/debian/patches/.gitignore
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/patches/.gitignore
diff --git a/ubuntu/precise/applications/knetstats/debian/rules b/ubuntu/precise/applications/knetstats/debian/rules
new file mode 100755
index 000000000..62349e5af
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_knetstats-trinity = knetstats.1
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+build/knetstats-trinity::
+ docbook2x-man debian/knetstats.1.docbook
+
+clean::
+ rm -f knetstats.1
diff --git a/ubuntu/precise/applications/knetstats/debian/source/format b/ubuntu/precise/applications/knetstats/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/precise/applications/knetstats/debian/source/options b/ubuntu/precise/applications/knetstats/debian/source/options
new file mode 100644
index 000000000..9d7c8e036
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/source/options
@@ -0,0 +1,6 @@
+# Use bzip2 instead of gzip
+compression = "bzip2"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/precise/applications/knetstats/debian/watch b/ubuntu/precise/applications/knetstats/debian/watch
new file mode 100644
index 000000000..8d12f40b0
--- /dev/null
+++ b/ubuntu/precise/applications/knetstats/debian/watch
@@ -0,0 +1,3 @@
+version=3
+
+http://sf.net/knetstats/knetstats-(.*)\.tar\.bz2