summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/knights/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/knights/debian/rules')
-rwxr-xr-xubuntu/precise/applications/knights/debian/rules116
1 files changed, 0 insertions, 116 deletions
diff --git a/ubuntu/precise/applications/knights/debian/rules b/ubuntu/precise/applications/knights/debian/rules
deleted file mode 100755
index f4f406c79..000000000
--- a/ubuntu/precise/applications/knights/debian/rules
+++ /dev/null
@@ -1,116 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
--include debian/debiandirs
-
-debian/knights.xpm: media/hi32-app-knights.png
- convert $< $@
-
-
-config.status: configure
- dh_testdir
-
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- if [ -f doc/Makefile.in ]; then cp doc/Makefile.in doc/Makefile.in.backup; else mv doc/Makefile.in.backup doc/Makefile.in; fi
- CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --disable-debug --disable-rpath --sysconfdir=/etc --includedir=/opt/trinity/include/tde --infodir=/opt/trinity/share/info --mandir=/opt/trinity/share/man --with-qt-dir=/usr/share/qt3 --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-
-build: build-stamp
-
-build-stamp: config.status debian/knights.xpm
- dh_testdir
- $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f po/de.gmo
- rm -f build-stamp
-
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- [ ! -f Makefile ] || $(MAKE) distclean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- $(MAKE) install DESTDIR=$(CURDIR)/debian/knights-trinity
- dh_install debian/knights.xpm /opt/trinity/share/pixmaps/
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installmenu
- dh_icons
- dh_installman debian/knights.1
- mv debian/knights-trinity/usr/share/man debian/knights-trinity/opt/trinity/share/
- dh_link
- dh_strip
- dh_compress -X.docbook
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install