summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/tellico/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/tellico/debian/rules')
-rwxr-xr-xubuntu/precise/applications/tellico/debian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/ubuntu/precise/applications/tellico/debian/rules b/ubuntu/precise/applications/tellico/debian/rules
index 84b8312a4..9e404eabf 100755
--- a/ubuntu/precise/applications/tellico/debian/rules
+++ b/ubuntu/precise/applications/tellico/debian/rules
@@ -12,6 +12,9 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -149,7 +152,7 @@ binary-indep: build install
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
# Build architecture-dependent files here.
binary-arch: build install
@@ -171,7 +174,7 @@ binary-arch: build install
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
- dh_builddeb -a
+ dh_builddeb -a $(DEB_DH_BUILDDEB_ARGS)
binary: binary-arch binary-indep
.PHONY: build clean binary-indep binary-arch binary install