summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/yakuake/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/yakuake/debian/rules')
-rwxr-xr-xubuntu/precise/applications/yakuake/debian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/yakuake/debian/rules b/ubuntu/precise/applications/yakuake/debian/rules
new file mode 100755
index 000000000..f5bd922f5
--- /dev/null
+++ b/ubuntu/precise/applications/yakuake/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+#There is not any interesting doc to install.
+INSTALL_DOCS_ALL :=
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+### Libtool and Automake updates
+post-patches:: debian/stamp-autothings-update
+debian/stamp-autothings-update:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+
+ touch $@
+
+clean::
+ rm -f debian/stamp-autothings-update
+