summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/dependencies/tqscintilla/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/dependencies/tqscintilla/debian/rules')
-rwxr-xr-xubuntu/precise/dependencies/tqscintilla/debian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/ubuntu/precise/dependencies/tqscintilla/debian/rules b/ubuntu/precise/dependencies/tqscintilla/debian/rules
index 36df66cc9..8dfaa3377 100755
--- a/ubuntu/precise/dependencies/tqscintilla/debian/rules
+++ b/ubuntu/precise/dependencies/tqscintilla/debian/rules
@@ -5,6 +5,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# This is the debhelper compatibility version to use.
export QTDIR=/usr/share/tqt3
export QMAKESPEC=$(QTDIR)/mkspecs/linux-g++
@@ -82,7 +85,7 @@ binary-indep: build install
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
# Build architecture-dependent files here.
binary-arch: build install
@@ -100,7 +103,7 @@ binary-arch: build install
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
- dh_builddeb -a
+ dh_builddeb -a $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure