summaryrefslogtreecommitdiffstats
path: root/kate/cppsymbolviewer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kate/cppsymbolviewer/Makefile.am')
-rw-r--r--kate/cppsymbolviewer/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kate/cppsymbolviewer/Makefile.am b/kate/cppsymbolviewer/Makefile.am
new file mode 100644
index 0000000..8bf46f0
--- /dev/null
+++ b/kate/cppsymbolviewer/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = katecppsymbolviewerplugin.la
+
+katecppsymbolviewerplugin_la_SOURCES = cpp_parser.cpp tcl_parser.cpp plugin_katesymbolviewer.cpp
+katecppsymbolviewerplugin_la_LIBADD = -lkateinterfaces
+katecppsymbolviewerplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+pluginsdir = $(kde_datadir)/kate/plugins/katecppsymbolviewer
+plugins_DATA = ui.rc
+
+kde_services_DATA = katecppsymbolviewer.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/katecppsymbolviewer.pot