summaryrefslogtreecommitdiffstats
path: root/kate/filetemplates/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kate/filetemplates/plugin/CMakeLists.txt')
-rw-r--r--kate/filetemplates/plugin/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kate/filetemplates/plugin/CMakeLists.txt b/kate/filetemplates/plugin/CMakeLists.txt
new file mode 100644
index 0000000..d80a9fe
--- /dev/null
+++ b/kate/filetemplates/plugin/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2013 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### katefiletemplates (kpart) #################
+
+tde_add_kpart( katefiletemplates AUTOMOC
+ SOURCES filetemplates.cpp
+ LINK kateinterfaces-shared knewstuff-shared katepartinterfaces-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES ui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kate/plugins/katefiletemplates
+)
+
+install( FILES katetemplate.xml
+ DESTINATION ${DATA_INSTALL_DIR}/katepart/syntax
+)