summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-08-25 15:20:08 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-01 19:02:11 +0200
commit0484f60a689b1334f0b5db9865b89efda71fc848 (patch)
treefd8df05e75e1413ed9ae85fb9cdf2956f4420d76 /CMakeLists.txt
parente95277074ee736e5043f9e8bebc0eaf45e86396c (diff)
downloadtdeadmin-0484f60a689b1334f0b5db9865b89efda71fc848.tar.gz
tdeadmin-0484f60a689b1334f0b5db9865b89efda71fc848.zip
cmake: Add option for GCC hidden visibility
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4aae8e03369bf188b6300f75745e6cc837889157)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e4f81c..425070e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,7 +38,8 @@ tde_setup_paths( )
##### optional stuff ############################
-
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules #####