summaryrefslogtreecommitdiffstats
path: root/lilo-config/kde-qt-common/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-08-25 13:53:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-01 19:02:11 +0200
commite95277074ee736e5043f9e8bebc0eaf45e86396c (patch)
treef262cab4686e9bd084899af9a9db492666dd53c8 /lilo-config/kde-qt-common/CMakeLists.txt
parent33423a846944b30830d67898dd97493f0e1844c0 (diff)
downloadtdeadmin-e95277074ee736e5043f9e8bebc0eaf45e86396c.tar.gz
tdeadmin-e95277074ee736e5043f9e8bebc0eaf45e86396c.zip
cmake lilo-config: Always add the USE_KDE definition
There is no reason to build a TQt-only frontend in TDE Fix the names of the auxiliary library targets Fix includes folders Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 48c6bba031ea37591a821d9554dd292aee938d58)
Diffstat (limited to 'lilo-config/kde-qt-common/CMakeLists.txt')
-rw-r--r--lilo-config/kde-qt-common/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/lilo-config/kde-qt-common/CMakeLists.txt b/lilo-config/kde-qt-common/CMakeLists.txt
index 81e638a..37ee790 100644
--- a/lilo-config/kde-qt-common/CMakeLists.txt
+++ b/lilo-config/kde-qt-common/CMakeLists.txt
@@ -4,6 +4,8 @@ include_directories(
${CMAKE_BINARY_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../common
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
)
@@ -14,9 +16,9 @@ link_directories(
)
-##### widgets (static) ##########################
+##### liloconfig-widgets (static) ###############
-tde_add_library( widgets STATIC_PIC AUTOMOC
+tde_add_library( liloconfig-widgets STATIC_PIC AUTOMOC
SOURCES mainwidget.cpp general.cpp images.cpp expert.cpp EditWidget.cpp
- LINK common-shared
+ LINK liloconfig-common-static
)