summaryrefslogtreecommitdiffstats
path: root/blinken/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'blinken/src/CMakeLists.txt')
-rw-r--r--blinken/src/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/blinken/src/CMakeLists.txt b/blinken/src/CMakeLists.txt
new file mode 100644
index 00000000..f8ccd4b7
--- /dev/null
+++ b/blinken/src/CMakeLists.txt
@@ -0,0 +1,51 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### blinken (executable)
+
+tde_add_executable( blinken AUTOMOC
+
+ SOURCES
+ main.cpp
+ blinken.cpp
+ artsplayer.cpp
+ blinkengame.cpp
+ number.cpp
+ highscoredialog.cpp
+ counter.cpp
+ fontutils.cpp
+ fontchecker.cpp
+ button.cpp
+ settings.kcfgc
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ artskde-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES blinken.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install(
+ FILES blinken.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)