summaryrefslogtreecommitdiffstats
path: root/kbruch/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kbruch/CMakeLists.txt')
-rw-r--r--kbruch/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/kbruch/CMakeLists.txt b/kbruch/CMakeLists.txt
new file mode 100644
index 00000000..192ddd69
--- /dev/null
+++ b/kbruch/CMakeLists.txt
@@ -0,0 +1,8 @@
+add_subdirectory( src )
+add_subdirectory( testcases )
+
+
+file( STRINGS "VERSION" _KBRUCH_VERSION )
+file( WRITE ${CMAKE_CURRENT_SOURCE_DIR}/src/version.h
+ "#undef KBRUCH_VERSION\n#define KBRUCH_VERSION \"${_KBRUCH_VERSION}\""
+)