summaryrefslogtreecommitdiffstats
path: root/keduca/keducabuilder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'keduca/keducabuilder/CMakeLists.txt')
-rw-r--r--keduca/keducabuilder/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/keduca/keducabuilder/CMakeLists.txt b/keduca/keducabuilder/CMakeLists.txt
new file mode 100644
index 00000000..92e6d7e3
--- /dev/null
+++ b/keduca/keducabuilder/CMakeLists.txt
@@ -0,0 +1,45 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/keduca/libkeduca
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### keducabuilder (executable)
+
+tde_add_executable( keducabuilder AUTOMOC
+
+ SOURCES
+ kcontroladdeditbase.ui
+ keducaeditorstartdialogbase.ui
+ keducaeditorstartdialog.cpp
+ ktagcombobox.cpp
+ klangcombo.cpp
+ kcontrolheader.cpp
+ keducabuilder.cpp
+ kcontroladdedit.cpp
+ main.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ keduca-static
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES keducabuilderui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/keduca
+)