summaryrefslogtreecommitdiffstats
path: root/libtdeedu/tdeeduplot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtdeedu/tdeeduplot/CMakeLists.txt')
-rw-r--r--libtdeedu/tdeeduplot/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/libtdeedu/tdeeduplot/CMakeLists.txt b/libtdeedu/tdeeduplot/CMakeLists.txt
new file mode 100644
index 00000000..1fa82598
--- /dev/null
+++ b/libtdeedu/tdeeduplot/CMakeLists.txt
@@ -0,0 +1,37 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeeduplot (shared)
+
+tde_add_library( tdeeduplot SHARED AUTOMOC
+
+ SOURCES
+ kplotobject.cpp
+ kplotaxis.cpp
+ kplotwidget.cpp
+ LINK
+ tdecore-shared
+
+ VERSION 1.2.0
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kplotobject.h kplotaxis.h kplotwidget.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/libtdeedu
+)